Skip to content

← Actionable
Critical, CVSS 10.0amended

Flyto2 Core: Arbitrary file write via image.download (and other file-writing modules)

CVE-2026-67429GHSA-2956-977x-2w3r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flyto-core 2.26.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:H
EPSS
  • CVE-2026-67429: 0.57% estimated exploitation activity in the next 30 days; percentile 47.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary image.download fetches a URL and writes the response to disk. It does not use the central path guard (validatepathwithenvconfig, which confines writes to FLYTOSANDBOXDIR); instead it confines the output to outputdir, but outputdir is itself a caller parameter. Since the attacker sets both the target and the base it is checked against, the check is meaningless, and attacker-controlled bytes (the HTTP response) land at any absolute path the process can write. Affected code src/core/modules/atomic/image/download.py: commonpath is used correctly, but the base is caller-supplied, so setting outputdir='/' passes any target. file.write, by contrast, uses validatepathwithenvconfig() and stays inside FLYTOSANDBOXDIR. This is not isolated to image.download. Most other file-writing modules write to a caller outputpath with no path check at all: image.convert, image.resize, image.crop, image.compress, image.rotate, image.watermark, image.qrcodegenerate, document.excelwrite,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2956-977x-2w3r

  2. Revision 2 · amended ·

    Amended from osv record GHSA-2956-977x-2w3r

  3. Revision 1 · created ·

    Published from ghsa record GHSA-2956-977x-2w3r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67429

Advisory: Flyto2 Core: Arbitrary file write via image.download (and other file-writing modules)
IDs: CVE-2026-67429, GHSA-2956-977x-2w3r
Record: https://patchnext.com/advisories/cve-2026-67429 (revision 3, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flyto-core 2.26.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI flyto-core: affected < 2.26.7; fixed in 2.26.7

## Suggested inspection (read-only)
- `python -m pip show flyto-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flyto-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2956-977x-2w3r (GitHub-reviewed advisory GHSA-2956-977x-2w3r lists affected ranges: PyPI flyto-core >=0 <2.26.7)
- Verified: https://osv.dev/vulnerability/GHSA-2956-977x-2w3r (OSV record GHSA-2956-977x-2w3r lists affected ranges: PyPI flyto-core >=0 <2.26.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…