Flyto2 Core: Multiple HTTP-family modules fetch client-controlled URLs without the SSRF guard their siblings apply (SSRF to internal/metadata)
CVE-2026-67428GHSA-pgwh-4jj4-qm8v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flyto-core 2.26.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI flyto-core
- Affected
- <= 2.26.6
- Fixed in
- 2.26.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pgwh-4jj4-qm8v lists affected ranges: PyPI flyto-core >=0 <=2.26.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2026-67428: 0.41% estimated exploitation activity in the next 30 days; percentile 35.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Numerous HTTP-emitting modules (core.api.httpget, core.api.httppost, graphql.query/graphql.mutation, monitor.httpcheck, communication.slacksend, notification.{discord,slack,teams}.sendmessage, ai.visionanalyze [anthropic path], verify.visualdiff, browser.proxyrotate, and the agent/llm inline baseurl branch) perform outbound requests to a fully client-controlled URL without calling the project's own SSRF guard (validateurlwithenvconfig) that their sibling modules apply. An authenticated workflow-author can point the URL at the cloud metadata IP (169.254.169.254), a loopback/RFC1918 host, or any internal host and read the response, yielding cloud-metadata credential theft and internal service read/write. Root Cause The SSRF guard is per-module (there is NO global egress interception). Each module must call validateurlwithenvconfig before issuing a request. The listed modules never call it — they only carry an ssrfprotected metadata tag string which enforces nothing. Exemplar:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pgwh-4jj4-qm8v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-67428 Advisory: Flyto2 Core: Multiple HTTP-family modules fetch client-controlled URLs without the SSRF guard their siblings apply (SSRF to internal/metadata) IDs: CVE-2026-67428, GHSA-pgwh-4jj4-qm8v Record: https://patchnext.com/advisories/cve-2026-67428 (revision 1, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flyto-core 2.26.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI flyto-core: affected <= 2.26.6; fixed in 2.26.7 ## Suggested inspection (read-only) - `python -m pip show flyto-core`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flyto-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pgwh-4jj4-qm8v (GitHub-reviewed advisory GHSA-pgwh-4jj4-qm8v lists affected ranges: PyPI flyto-core >=0 <=2.26.6) Commands are suggestions: review each one before running it.
Loading voting…