Skip to content

← Actionable
High, CVSS 8.6

Flyto2 Core: ${env.VAR} interpolation reads any env secret despite env.get being denylisted

CVE-2026-67427GHSA-hr7p-wg7r-hg9m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flyto-core 2.26.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-67427: 0.45% estimated exploitation activity in the next 30 days; percentile 38.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The capability policy denies the env.get and env.loaddotenv modules by default, with the stated reason that they read arbitrary host environment variables (API keys, DSNs) and are a secret-exfil risk. But the workflow engine's variable resolver expands ${env.VAR} for any environment variable with no allowlist and no policy check, so the exact capability the denylist blocks is available to any workflow parameter. The resolved secret can then be sent out through any allowed module. Affected code src/core/engine/variableresolver.py: The module policy (enforcemodulepolicy in modulepolicy.py) gates module execution at BaseModule.run, but ${...} interpolation happens earlier in the engine and is not subject to it. So denylisting env.get does not actually stop a workflow from reading host env secrets. Reproduction Save as envbypasspoc.py, run with PYTHONPATH=src/src python envbypasspoc.py. Output: env.get is denied, yet ${env.AWSSECRETACCESSKEY} reads the same secret and drops it…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hr7p-wg7r-hg9m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67427

Advisory: Flyto2 Core: ${env.VAR} interpolation reads any env secret despite env.get being denylisted
IDs: CVE-2026-67427, GHSA-hr7p-wg7r-hg9m
Record: https://patchnext.com/advisories/cve-2026-67427 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flyto-core 2.26.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI flyto-core: affected < 2.26.7; fixed in 2.26.7

## Suggested inspection (read-only)
- `python -m pip show flyto-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flyto-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hr7p-wg7r-hg9m (GitHub-reviewed advisory GHSA-hr7p-wg7r-hg9m lists affected ranges: PyPI flyto-core >=0 <2.26.7)

Commands are suggestions: review each one before running it.

Loading voting…