Skip to content

← Actionable
Critical, CVSS 9.3amended

Flyto2 Core: Unauthenticated flyto-verification /run: callback_url SSRF and internal runner-secret exfiltration

CVE-2026-67426GHSA-jx74-cqjv-2c67

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flyto-core 2.26.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI flyto-core

    Affected
    >= 2.26.6, < 2.26.7
    Fixed in
    2.26.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-67426: 0.37% estimated exploitation activity in the next 30 days; percentile 31.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The standalone flyto-verification service exposes POST /run with no authentication, on all interfaces (0.0.0.0:8344 per the shipped Dockerfile). The request body's callbackurl is used verbatim for an outbound POST that unconditionally attaches X-Internal-Key: $FLYTORUNNERSECRET. The callbackurl bypasses the service's targetallowed allowlist (which only inspects params.targeturl) and is never passed through any SSRF guard. This yields (a) unauthenticated SSRF to internal/metadata endpoints with an attacker-controlled JSON body, and (b) exfiltration of the internal runner secret to an attacker-controlled host — allowing forged authenticated callbacks to the real engine. Root Cause - src/core/verificationservice.py:363-364 — /run has no Depends/auth dependency. - resolvecallbackurl returns the client callbackurl verbatim (:315-316). - postcallback attaches X-Internal-Key: $FLYTORUNNERSECRET whenever the env var is set (:327-335). - targetallowed only gates params.targeturl…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jx74-cqjv-2c67

  2. Revision 2 · amended ·

    Amended from osv record GHSA-jx74-cqjv-2c67

  3. Revision 1 · created ·

    Published from ghsa record GHSA-jx74-cqjv-2c67

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67426

Advisory: Flyto2 Core: Unauthenticated flyto-verification /run: callback_url SSRF and internal runner-secret exfiltration
IDs: CVE-2026-67426, GHSA-jx74-cqjv-2c67
Record: https://patchnext.com/advisories/cve-2026-67426 (revision 3, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flyto-core 2.26.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI flyto-core: affected >= 2.26.6, < 2.26.7; fixed in 2.26.7

## Suggested inspection (read-only)
- `python -m pip show flyto-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flyto-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jx74-cqjv-2c67 (GitHub-reviewed advisory GHSA-jx74-cqjv-2c67 lists affected ranges: PyPI flyto-core >=2.26.6 <2.26.7)
- Verified: https://osv.dev/vulnerability/GHSA-jx74-cqjv-2c67 (OSV record GHSA-jx74-cqjv-2c67 lists affected ranges: PyPI flyto-core >=2.26.6 <2.26.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…