Skip to content

← Actionable
Medium, CVSS 5.3

Guzzle: Unbounded response cookies risk denial of service

CVE-2026-67353GHSA-f283-ghqc-fg79

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (guzzlehttp/guzzle 7.15.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-67353: 0.42% estimated exploitation activity in the next 30 days; percentile 36.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In affected versions, Guzzle's built-in CookieJar accepts any number of Set-Cookie header fields from one response, with no limit on the size of each field. When a later request matches the stored cookies, Guzzle places every match into one generated Cookie header without limiting the number of cookies or the total header length. A malicious or compromised server can therefore return many large cookies, causing Guzzle to store attacker-controlled data in memory and copy it into later request headers. This can increase memory use and processing time. It can also make later requests fail when the generated header exceeds a limit in a handler, HTTP implementation, proxy, or destination server. A server on one sibling host, such as attacker.example.com, can also set parent-domain cookies that are later selected for another sibling, such as service.example.com. The denial can therefore affect a different service that uses the same jar. An application is affected when it enables the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f283-ghqc-fg79

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67353

Advisory: Guzzle: Unbounded response cookies risk denial of service
IDs: CVE-2026-67353, GHSA-f283-ghqc-fg79
Record: https://patchnext.com/advisories/cve-2026-67353 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: guzzlehttp/guzzle 7.15.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist guzzlehttp/guzzle: affected < 7.15.1; fixed in 7.15.1

## Suggested inspection (read-only)
- Packagist guzzlehttp/guzzle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on guzzlehttp/guzzle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f283-ghqc-fg79 (GitHub-reviewed advisory GHSA-f283-ghqc-fg79 lists affected ranges: Packagist guzzlehttp/guzzle >=0 <7.15.1)

Commands are suggestions: review each one before running it.

Loading voting…