Skip to content

← Actionable
High, CVSS 7.5amended

undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse

CVE-2026-6734GHSA-hm92-r4w5-c3mj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.2.0, 7.28.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm undici

    Affected
    >= 7.23.0, < 7.28.0>= 8.0.0, < 8.2.0
    Fixed in
    7.28.0, 8.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-6734: 0.34% estimated exploitation activity in the next 30 days; percentile 28.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When using Socks5ProxyAgent, undici reuses a single connection pool across different origins without verifying that the pool's origin matches the requested origin. All requests are dispatched through the pool connected to the first origin, regardless of the intended destination. This causes cross-origin request routing: credentials and request data intended for origin B are sent to origin A, responses from the wrong origin are trusted, and HTTPS requests may be silently downgraded to HTTP. Impacted users are applications that use Socks5ProxyAgent (directly or via setGlobalDispatcher) and make requests to more than one origin. This was introduced in undici 7.23.0 via #4385 and affects all versions through 8.1.0. Patches Upgrade to undici v7.28.0 or v8.2.0 Workarounds Use a separate Socks5ProxyAgent instance per origin, or avoid using Socks5ProxyAgent with multiple origins.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hm92-r4w5-c3mj

  2. Revision 1 · created ·

    Published from osv record GHSA-hm92-r4w5-c3mj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-6734

Advisory: undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse
IDs: CVE-2026-6734, GHSA-hm92-r4w5-c3mj
Record: https://patchnext.com/advisories/cve-2026-6734 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: undici 8.2.0, 7.28.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm undici: affected >= 7.23.0, < 7.28.0; >= 8.0.0, < 8.2.0; fixed in 7.28.0, 8.2.0

## Suggested inspection (read-only)
- `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on undici.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hm92-r4w5-c3mj (OSV record GHSA-hm92-r4w5-c3mj lists affected ranges: npm undici >=7.23.0 =8.0.0 <8.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hm92-r4w5-c3mj (GitHub-reviewed advisory GHSA-hm92-r4w5-c3mj lists affected ranges: npm undici >=7.23.0 =8.0.0 <8.2.0)

Commands are suggestions: review each one before running it.

Loading voting…