Skip to content

← Actionable
Medium, CVSS 5.1amended

JupyterLab: Stored XSS in extension manager through package metadata unsanitized URI protocol

CVE-2026-67338GHSA-vmhf-c436-hxj4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterlab 4.5.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-67338: 0.30% estimated exploitation activity in the next 30 days; percentile 23.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A malicious PyPI package can place a javascript: URL in its [project.urls] metadata. JupyterLab's Extension Manager renders this as the extension's home-page link without validating the protocol, so a user who clicks the extension name executes attacker-controlled JavaScript in the JupyterLab origin. Details One of the PyPI package's URL (jupyterlab/extensions/pypi.py) is copied straight into the homepageurl rendered by the frontend in packages/extensionmanager/src/widget.tsx#L77-L88. Impact An attacker needs to publish a package to PyPI (no access to the target). When the package appears in a victim's extension manager list and the victim clicks the extension name, the payload runs in the JupyterLab origin. Preconditions: Extension Manager enabled with the default PyPI source, the malicious package appears in the victim's list/search results. Patches Patched in 4.5.9, commits 4e61e07 and d5d961f

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vmhf-c436-hxj4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vmhf-c436-hxj4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67338

Advisory: JupyterLab: Stored XSS in extension manager through package metadata unsanitized URI protocol
IDs: CVE-2026-67338, GHSA-vmhf-c436-hxj4
Record: https://patchnext.com/advisories/cve-2026-67338 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyterlab 4.5.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyterlab: affected <= 4.5.8; fixed in 4.5.9

## Suggested inspection (read-only)
- `python -m pip show jupyterlab`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyterlab.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vmhf-c436-hxj4 (OSV record GHSA-vmhf-c436-hxj4 lists affected ranges: PyPI jupyterlab >=0 <4.5.9 (fixed))
- Verified: https://github.com/advisories/GHSA-vmhf-c436-hxj4 (GitHub-reviewed advisory GHSA-vmhf-c436-hxj4 lists affected ranges: PyPI jupyterlab >=0 <=4.5.8)

Commands are suggestions: review each one before running it.

Loading voting…