Better Auth: OAuth callback accepts mismatched state when cookie-backed state storage is used without PKCE
CVE-2026-67335GHSA-wxw3-q3m9-c3jr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.6.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm better-auth
- Affected
- < 1.6.2
- Fixed in
- 1.6.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wxw3-q3m9-c3jr lists affected ranges: npm better-auth >=0 <1.6.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wxw3-q3m9-c3jr lists affected ranges: npm better-auth >=0 <1.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-67335: 0.28% estimated exploitation activity in the next 30 days; percentile 20.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Am I affected? Users are affected if all of the following are true: - The application uses better-auth at a version below 1.6.2 (or @better-auth/sso paired with such a version). - betterAuth({ account: { storeStateStrategy } }) is set to "cookie". The default "database" is not affected. - The application wires at least one OAuth provider through genericOAuth({ config }) with pkce: false, or it supplies a custom getToken or tokenUrl that does not require the stored codeVerifier. Stock social providers with PKCE on are not affected. - The provider returns arbitrary code values to the configured callback URL. If users are on better-auth@1.6.2 or later, they are not affected. Fix: 1. Upgrade to better-auth@1.6.2 or later (current stable is 1.6.10). 2. If users cannot upgrade, see workarounds below. Summary In parseGenericState, the cookie branch decrypted the oauthstate cookie and validated expiry, but did not compare the incoming OAuth state query parameter to the nonce that…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wxw3-q3m9-c3jr
- Revision 1 · created ·
Published from osv record GHSA-wxw3-q3m9-c3jr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-67335 Advisory: Better Auth: OAuth callback accepts mismatched `state` when cookie-backed state storage is used without PKCE IDs: CVE-2026-67335, GHSA-wxw3-q3m9-c3jr Record: https://patchnext.com/advisories/cve-2026-67335 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: better-auth 1.6.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm better-auth: affected < 1.6.2; fixed in 1.6.2 ## Suggested inspection (read-only) - `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on better-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wxw3-q3m9-c3jr (OSV record GHSA-wxw3-q3m9-c3jr lists affected ranges: npm better-auth >=0 <1.6.2 (fixed)) - Verified: https://github.com/advisories/GHSA-wxw3-q3m9-c3jr (GitHub-reviewed advisory GHSA-wxw3-q3m9-c3jr lists affected ranges: npm better-auth >=0 <1.6.2) Commands are suggestions: review each one before running it.
Loading voting…