Skip to content

← Actionable
Low, CVSS 3.8amended

Better Auth: Stale sessions persist after user deletion across admin, anonymous, and SCIM flows

CVE-2026-67334GHSA-2vg6-77g8-24mp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.6.11; @better-auth/scim 1.6.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-67334: 0.32% estimated exploitation activity in the next 30 days; percentile 25.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Am I affected? Users are affected if all of the following are true: - They configure secondaryStorage on betterAuth(...) (Redis, KV, or any external session cache). - session.storeSessionInDatabase is left unset or set to false (the default). - Their application's deployment uses one or more of: - The admin plugin and calls auth.api.removeUser(...) or authClient.admin.removeUser(...). - The anonymous plugin and exposes /delete-anonymous-user or relies on the after-link hook to clean up the anonymous user. - The @better-auth/scim plugin and exposes DELETE /scim/v2/Users/:userId. If storeSessionInDatabase is true, sessions are also written to the database, and the database delete cascades; users are not affected. Fix: 1. Upgrade to better-auth@<patched-version or later (and @better-auth/scim@<patched-version if they use SCIM). 2. If they cannot upgrade, see workarounds below. Summary When secondaryStorage is configured and storeSessionInDatabase is false, three user-deletion endpoints…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2vg6-77g8-24mp

  2. Revision 1 · created ·

    Published from osv record GHSA-2vg6-77g8-24mp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67334

Advisory: Better Auth: Stale sessions persist after user deletion across admin, anonymous, and SCIM flows
IDs: CVE-2026-67334, GHSA-2vg6-77g8-24mp
Record: https://patchnext.com/advisories/cve-2026-67334 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: better-auth 1.6.11; @better-auth/scim 1.6.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm better-auth: affected >= 0.3.4, < 1.6.11; fixed in 1.6.11
- npm @better-auth/scim: affected >= 1.6.0, < 1.6.11; fixed in 1.6.11

## Suggested inspection (read-only)
- `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @better-auth/scim --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on better-auth, @better-auth/scim.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2vg6-77g8-24mp (OSV record GHSA-2vg6-77g8-24mp lists affected ranges: npm better-auth >=0.3.4 =1.6.0 <1.6.11 (fixed))
- Verified: https://github.com/advisories/GHSA-2vg6-77g8-24mp (GitHub-reviewed advisory GHSA-2vg6-77g8-24mp lists affected ranges: npm better-auth >=0.3.4 =1.6.0 <1.6.11)

Commands are suggestions: review each one before running it.

Loading voting…