Skip to content

← Actionable
High, CVSS 7.7amended

Better Auth has stored XSS in the auth-server origin via javascript: redirect_uri in oidc-provider and mcp

CVE-2026-67333GHSA-86j7-9j95-vpqj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.7.0-beta.4, 1.6.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm better-auth

    Affected
    < 1.6.13>= 1.7.0-beta.0, < 1.7.0-beta.4
    Fixed in
    1.6.13, 1.7.0-beta.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-67333: 0.26% estimated exploitation activity in the next 30 days; percentile 18.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Am I affected? Check each condition. Users are affected when all of the first three hold. - Their application enables the oidc-provider plugin or the mcp plugin from better-auth/plugins. The mcp plugin wraps the same provider and carries the same defect. Both are on the migration path to @better-auth/oauth-provider, which is not affected. - Their application better-auth version is 1.6.12 or earlier on the stable line, or any 1.7.0-beta build on the pre-release line. Both release lines carry the same defect. - Their application consent page is a client component that reads redirectURI from the authClient.oauth2.consent(...) response and assigns it to a browser navigation target such as window.location.href, location.assign, or location.replace. Two conditions raise an application's exposure: - It sets allowDynamicClientRegistration: true. Client registration is then unauthenticated, so any visitor can plant the malicious client. The default is false, which limits planting to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-86j7-9j95-vpqj

  2. Revision 1 · created ·

    Published from osv record GHSA-86j7-9j95-vpqj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67333

Advisory: Better Auth has stored XSS in the auth-server origin via javascript: redirect_uri in oidc-provider and mcp
IDs: CVE-2026-67333, GHSA-86j7-9j95-vpqj
Record: https://patchnext.com/advisories/cve-2026-67333 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: better-auth 1.7.0-beta.4, 1.6.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm better-auth: affected < 1.6.13; >= 1.7.0-beta.0, < 1.7.0-beta.4; fixed in 1.6.13, 1.7.0-beta.4

## Suggested inspection (read-only)
- `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on better-auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-86j7-9j95-vpqj (OSV record GHSA-86j7-9j95-vpqj lists affected ranges: npm better-auth >=0 =1.7.0-beta.0 <1.7.0-beta.4 (fixed))
- Verified: https://github.com/advisories/GHSA-86j7-9j95-vpqj (GitHub-reviewed advisory GHSA-86j7-9j95-vpqj lists affected ranges: npm better-auth >=0 =1.7.0-beta.0 <1.7.0-beta.4)

Commands are suggestions: review each one before running it.

Loading voting…