@better-auth/oauth-provider may provide access tokens for unauthorized audiences via unbound resource indicators
CVE-2026-67332GHSA-p2fr-6hmx-4528
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@better-auth/oauth-provider 1.7.0-beta.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @better-auth/oauth-provider
- Affected
- >= 1.4.8, < 1.7.0-beta.4
- Fixed in
- 1.7.0-beta.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p2fr-6hmx-4528 lists affected ranges: npm @better-auth/oauth-provider >=1.4.8 <1.7.0-beta.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p2fr-6hmx-4528 lists affected ranges: npm @better-auth/oauth-provider >=1.4.8 <1.7.0-beta.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-67332: 0.26% estimated exploitation activity in the next 30 days; percentile 17.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Am I affected? Users are affected if all of the following hold: - Their application depends on @better-auth/oauth-provider on any stable 1.6.x release (the stable line is not patched) or on a pre-release before 1.7.0-beta.4. - Their application either configures validAudiences with more than one audience, or it issues JWT access tokens whose aud (resource) claim is consumed by their resource servers. - Their resource servers make authorization decisions based on that aud or resource value. A deployment with a single validAudiences entry (or the default, their server's base URL) cannot mint a token for a different audience. The provider rejects any resource outside the allowlist. Such a deployment still does not bind the resource to the authorization grant, so the spec-compliance gap remains even where cross-audience escalation does not apply. Fix: 1. Upgrade to @better-auth/oauth-provider@1.7.0-beta.4 (then 1.7.0), then run the schema migration (npx auth migrate). This is a breaking…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p2fr-6hmx-4528
- Revision 1 · created ·
Published from osv record GHSA-p2fr-6hmx-4528
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-67332 Advisory: @better-auth/oauth-provider may provide access tokens for unauthorized audiences via unbound resource indicators IDs: CVE-2026-67332, GHSA-p2fr-6hmx-4528 Record: https://patchnext.com/advisories/cve-2026-67332 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @better-auth/oauth-provider 1.7.0-beta.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @better-auth/oauth-provider: affected >= 1.4.8, < 1.7.0-beta.4; fixed in 1.7.0-beta.4 ## Suggested inspection (read-only) - `npm ls @better-auth/oauth-provider --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @better-auth/oauth-provider. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p2fr-6hmx-4528 (OSV record GHSA-p2fr-6hmx-4528 lists affected ranges: npm @better-auth/oauth-provider >=1.4.8 <1.7.0-beta.4 (fixed)) - Verified: https://github.com/advisories/GHSA-p2fr-6hmx-4528 (GitHub-reviewed advisory GHSA-p2fr-6hmx-4528 lists affected ranges: npm @better-auth/oauth-provider >=1.4.8 <1.7.0-beta.4) Commands are suggestions: review each one before running it.
Loading voting…