Skip to content

← Actionable
High, CVSS 8.3amended

@better-auth/scim: Account/provider takeover via missing owner binding on non-org SCIM providers

CVE-2026-67331GHSA-j8v8-g9cx-5qf4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@better-auth/scim 1.7.0-beta.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-67331: 0.39% estimated exploitation activity in the next 30 days; percentile 33.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Am I affected? Users are affected if all of these hold: - They install and register the @better-auth/scim plugin (plugins: [scim()]). - They create SCIM providers without an organizationId, that is, non-organization ("personal") providers. Organization-scoped providers are not affected because they enforce organization membership and role. - Their application's deployment has more than one authenticated user, so one account can target another user's provider. - They have not set providerOwnership: { enabled: true }. The SCIM management endpoints first shipped in 1.5.0, so every stable release from 1.5.0 onward is affected, and the stable line is not patched. On the pre-release line, builds through 1.7.0-beta.3 are affected, and 1.7.0-beta.4 carries the fix. Fix: 1. Upgrade to @better-auth/scim@1.7.0-beta.4 (then 1.7.0). This is a breaking change: it removes the providerOwnership option, makes owner binding mandatory, and adds a permanent scimProvider.userId column. 2. Run the schema…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j8v8-g9cx-5qf4

  2. Revision 1 · created ·

    Published from osv record GHSA-j8v8-g9cx-5qf4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67331

Advisory: @better-auth/scim: Account/provider takeover via missing owner binding on non-org SCIM providers
IDs: CVE-2026-67331, GHSA-j8v8-g9cx-5qf4
Record: https://patchnext.com/advisories/cve-2026-67331 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @better-auth/scim 1.7.0-beta.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @better-auth/scim: affected >= 1.5.0, < 1.7.0-beta.4; fixed in 1.7.0-beta.4

## Suggested inspection (read-only)
- `npm ls @better-auth/scim --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @better-auth/scim.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j8v8-g9cx-5qf4 (OSV record GHSA-j8v8-g9cx-5qf4 lists affected ranges: npm @better-auth/scim >=1.5.0 <1.7.0-beta.4 (fixed))
- Verified: https://github.com/advisories/GHSA-j8v8-g9cx-5qf4 (GitHub-reviewed advisory GHSA-j8v8-g9cx-5qf4 lists affected ranges: npm @better-auth/scim >=1.5.0 <1.7.0-beta.4)

Commands are suggestions: review each one before running it.

Loading voting…