Skip to content

← Actionable
Low, CVSS 3.7amended

undici vulnerable to HTTP response queue poisoning via keep-alive socket reuse

CVE-2026-6733GHSA-35p6-xmwp-9g52

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.5.0, 7.28.0, 6.27.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm undici

    Affected
    < 6.27.0>= 7.0.0, < 7.28.0>= 8.0.0, < 8.5.0
    Fixed in
    6.27.0, 7.28.0, 8.5.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-6733: 0.22% estimated exploitation activity in the next 30 days; percentile 12.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Undici's HTTP/1.1 client is vulnerable to response queue poisoning on reused keep-alive sockets. An attacker-controlled upstream server can inject an unsolicited HTTP/1.1 response onto an idle socket after a request completes. When the client dispatches the next request on that socket, it associates the injected response with the new request, causing responses to be delivered to the wrong requests. This requires an attacker-controlled or compromised upstream HTTP/1.1 server and keep-alive connection reuse. Patches Upgrade to undici v6.27.0, v7.28.0 or v8.5.0. Workarounds Disable keep-alive connection reuse by setting keepAliveTimeout: 0 on the Client or Pool.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-35p6-xmwp-9g52

  2. Revision 1 · created ·

    Published from osv record GHSA-35p6-xmwp-9g52

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-6733

Advisory: undici vulnerable to HTTP response queue poisoning via keep-alive socket reuse
IDs: CVE-2026-6733, GHSA-35p6-xmwp-9g52
Record: https://patchnext.com/advisories/cve-2026-6733 (revision 2, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: undici 8.5.0, 7.28.0, 6.27.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm undici: affected < 6.27.0; >= 7.0.0, < 7.28.0; >= 8.0.0, < 8.5.0; fixed in 6.27.0, 7.28.0, 8.5.0

## Suggested inspection (read-only)
- `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on undici.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-35p6-xmwp-9g52 (OSV record GHSA-35p6-xmwp-9g52 lists affected ranges: npm undici >=0 =7.0.0 =8.0.0 <8.5.0 (fixed))
- Verified: https://github.com/advisories/GHSA-35p6-xmwp-9g52 (GitHub-reviewed advisory GHSA-35p6-xmwp-9g52 lists affected ranges: npm undici >=0 =7.0.0 =8.0.0 <8.5.0)

Commands are suggestions: review each one before running it.

Loading voting…