Skip to content

← Actionable
High, CVSS 7.1amended

@better-auth/stripe: cross-organization billing tampering in organization subscription actions

CVE-2026-67329GHSA-h3rm-78g3-j7cp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@better-auth/stripe 1.7.0-beta.10, 1.6.21), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @better-auth/stripe

    Affected
    >= 1.4.11, < 1.6.21>= 1.7.0-beta.0, < 1.7.0-beta.10
    Fixed in
    1.6.21, 1.7.0-beta.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
EPSS
  • CVE-2026-67329: 0.31% estimated exploitation activity in the next 30 days; percentile 24.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Am I affected? You are affected if all of these are true: - You use @better-auth/stripe from version 1.4.11 up to a patched version below. This covers the stable line through 1.6.20 and every 1.7.0 beta through 1.7.0-beta.9. - The Stripe plugin has subscriptions turned on (subscription.enabled: true). - Organization subscriptions are turned on (organization.enabled: true) and you have set an authorizeReference callback. - A user can join more than one org. So a user can be a member of an org whose billing they should not manage. You are not affected if you only use user subscriptions. You are also not affected if org subscriptions are turned off. Summary An org subscription action can run against the wrong org. The actions are cancel, change plan, restore, and open the billing portal. The plugin checks permission against the org id in the request query string. It then runs the action against the caller's active org from their session. When these two ids differ, a member can act on…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h3rm-78g3-j7cp

  2. Revision 1 · created ·

    Published from osv record GHSA-h3rm-78g3-j7cp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67329

Advisory: @better-auth/stripe: cross-organization billing tampering in organization subscription actions
IDs: CVE-2026-67329, GHSA-h3rm-78g3-j7cp
Record: https://patchnext.com/advisories/cve-2026-67329 (revision 2, source checked 26 Oct 2026, 12:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @better-auth/stripe 1.7.0-beta.10, 1.6.21. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @better-auth/stripe: affected >= 1.4.11, < 1.6.21; >= 1.7.0-beta.0, < 1.7.0-beta.10; fixed in 1.6.21, 1.7.0-beta.10

## Suggested inspection (read-only)
- `npm ls @better-auth/stripe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @better-auth/stripe.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h3rm-78g3-j7cp (OSV record GHSA-h3rm-78g3-j7cp lists affected ranges: npm @better-auth/stripe >=1.4.11 =1.7.0-beta.0 <1.7.0-beta.10 (fixed))
- Verified: https://github.com/advisories/GHSA-h3rm-78g3-j7cp (GitHub-reviewed advisory GHSA-h3rm-78g3-j7cp lists affected ranges: npm @better-auth/stripe >=1.4.11 =1.7.0-beta.0 <1.7.0-beta.10)

Commands are suggestions: review each one before running it.

Loading voting…