Skip to content

← Actionable
High, CVSS 8.3amended

Better Auth: Account takeover via pre-account hijacking on magic-link and email-OTP sign-in

CVE-2026-67327GHSA-qq9h-g4jm-xgf3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.7.0-beta.10, 1.6.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm better-auth

    Affected
    >= 1.1.3, < 1.6.22>= 1.7.0-beta.0, < 1.7.0-beta.10
    Fixed in
    1.7.0-beta.10, 1.6.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-67327: 0.43% estimated exploitation activity in the next 30 days; percentile 37.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Am I affected You are affected if all of the following hold: - You run a better-auth version below 1.6.22, or a 1.7.0-beta below 1.7.0-beta.10. - You enable the magic-link plugin or the email-OTP plugin. - You also enable email and password sign-up with open registration. - An account can exist at an address before its owner first signs in with the passwordless flow. Summary An attacker can keep password access to a victim's account after the victim starts using it. The attack runs in three steps. First, with open registration, the attacker signs up using the victim's email and a password the attacker picks. The account stays unverified, so the attacker cannot use it yet. Later the real owner signs in with a magic link or an email OTP. That step marks the account verified, and the attacker's password now works on it. Details When an account already exists for an address, magic-link verification and email-OTP sign-in both sign in to that account. They mark it verified and issue a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qq9h-g4jm-xgf3

  2. Revision 1 · created ·

    Published from osv record GHSA-qq9h-g4jm-xgf3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67327

Advisory: Better Auth: Account takeover via pre-account hijacking on magic-link and email-OTP sign-in
IDs: CVE-2026-67327, GHSA-qq9h-g4jm-xgf3
Record: https://patchnext.com/advisories/cve-2026-67327 (revision 2, source checked 26 Oct 2026, 12:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: better-auth 1.7.0-beta.10, 1.6.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm better-auth: affected >= 1.1.3, < 1.6.22; >= 1.7.0-beta.0, < 1.7.0-beta.10; fixed in 1.7.0-beta.10, 1.6.22

## Suggested inspection (read-only)
- `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on better-auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qq9h-g4jm-xgf3 (OSV record GHSA-qq9h-g4jm-xgf3 lists affected ranges: npm better-auth >=1.1.3 =1.7.0-beta.0 <1.7.0-beta.10 (fixed))
- Verified: https://github.com/advisories/GHSA-qq9h-g4jm-xgf3 (GitHub-reviewed advisory GHSA-qq9h-g4jm-xgf3 lists affected ranges: npm better-auth >=1.1.3 =1.7.0-beta.0 <1.7.0-beta.10)

Commands are suggestions: review each one before running it.

Loading voting…