Skip to content

← Actionable
High, CVSS 8.8amended

GitPython: Command Injection via git long-option prefix abbreviation bypass of CVE-2026-42215 blocklist

CVE-2026-67325GHSA-2f96-g7mh-g2hx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gitpython 3.1.51), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI gitpython

    Affected
    <= 3.1.50
    Fixed in
    3.1.51

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-67325: 2.21% estimated exploitation activity in the next 30 days; percentile 82.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Command injection via long-option prefix abbreviation bypassing checkunsafeoptions (incomplete fix of CVE-2026-42215 / GHSA-rpm5-65cw-6hj4) Component: gitpython-developers/GitPython (PyPI: GitPython) Affected: all versions carrying the 3.1.47 blocklist fix, through current main (verified at commit 20c5e275, 3.1.50-42) Reporter: hackkim Summary The 3.1.47 fix for CVE-2026-42215 blocks dangerous git options (--upload-pack, --config, -c, -u for clone; --upload-pack for fetch/pull; --receive-pack, --exec for push) so callers cannot reach command-executing options unless they pass allowunsafeoptions=True. The fix canonicalizes an option name along one axis (underscore→hyphen via dashify) and checks it against an exact-match dict. It does not account for git's unambiguous long-option prefix abbreviation. Git accepts any unambiguous prefix of a long option (--upload-p, --upload-pa, --upload-pac all resolve to --upload-pack). So a kwarg key like uploadp canonicalizes to upload-p, misses the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2f96-g7mh-g2hx

  2. Revision 1 · created ·

    Published from osv record GHSA-2f96-g7mh-g2hx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67325

Advisory: GitPython: Command Injection via git long-option prefix abbreviation bypass of CVE-2026-42215 blocklist
IDs: CVE-2026-67325, GHSA-2f96-g7mh-g2hx
Record: https://patchnext.com/advisories/cve-2026-67325 (revision 2, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gitpython 3.1.51. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gitpython: affected <= 3.1.50; fixed in 3.1.51

## Suggested inspection (read-only)
- `python -m pip show gitpython`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gitpython.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2f96-g7mh-g2hx (OSV record GHSA-2f96-g7mh-g2hx lists affected ranges: PyPI gitpython >=0 <3.1.51 (fixed))
- Verified: https://github.com/advisories/GHSA-2f96-g7mh-g2hx (GitHub-reviewed advisory GHSA-2f96-g7mh-g2hx lists affected ranges: PyPI gitpython >=0 <=3.1.50)

Commands are suggestions: review each one before running it.

Loading voting…