Skip to content

← Actionable
High, CVSS 8.4amended

GitPython: command injection via unguarded Git options in Repo.archive(), git.ls_remote(), and arbitrary file overwrite via Repo.iter_commits() / Repo.blame()

CVE-2026-67323GHSA-956x-8gvw-wg5v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gitpython 3.1.51), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI gitpython

    Affected
    <= 3.1.50
    Fixed in
    3.1.51

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-67323: 1.25% estimated exploitation activity in the next 30 days; percentile 69.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary GitPython already know that --upload-pack / --exec are command-exec vectors, they are denylist in git/remote.py:535 and check by Git.checkunsafeoptions() (git/cmd.py:963), the thing is this check him he is only call from fetch, pull, push and clonefrom, everything else who build a git argv from caller values just go through, no check, three examples Code analysis Repo.archive (git/repo/base.py:1623) do self.git.archive("--", treeish, path, kwargs), the treeish is after the --, but the kwargs get dashify by transformkwarg (git/cmd.py:1487) and they land before it, so {"remote": ".", "exec": "<cmd"} give git archive --remote=. --exec=<cmd -- <rev, the --remote spawn the upload-archive helper and --exec choose which binary that is, done, default git config, no protocol.ext.allow needed, and archive already document caller kwargs (format, prefix, path) so pass a dict is normal usage repo.git.lsremote(url, uploadpack="<cmd"), same builder, same result, it's exactly the kwarg gap…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-956x-8gvw-wg5v

  2. Revision 1 · created ·

    Published from osv record GHSA-956x-8gvw-wg5v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67323

Advisory: GitPython: command injection via unguarded Git options in `Repo.archive()`, `git.ls_remote()`, and arbitrary file overwrite via `Repo.iter_commits()` / `Repo.blame()`
IDs: CVE-2026-67323, GHSA-956x-8gvw-wg5v
Record: https://patchnext.com/advisories/cve-2026-67323 (revision 2, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gitpython 3.1.51. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gitpython: affected <= 3.1.50; fixed in 3.1.51

## Suggested inspection (read-only)
- `python -m pip show gitpython`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gitpython.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-956x-8gvw-wg5v (OSV record GHSA-956x-8gvw-wg5v lists affected ranges: PyPI gitpython >=0 <3.1.51 (fixed))
- Verified: https://github.com/advisories/GHSA-956x-8gvw-wg5v (GitHub-reviewed advisory GHSA-956x-8gvw-wg5v lists affected ranges: PyPI gitpython >=0 <=3.1.50)

Commands are suggestions: review each one before running it.

Loading voting…