Skip to content

← Actionable
High, CVSS 7.5amended

GitPython: Environment-variable exfiltration via os.path.expandvars() on Repo.clone_from() URL

CVE-2026-67322GHSA-rwj8-pgh3-r573

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gitpython 3.1.52), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-67322: 0.33% estimated exploitation activity in the next 30 days; percentile 25.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Repo.clonefrom() passes the caller-supplied remote URL through Git.polishurl(), which on every non-Cygwin platform calls os.path.expandvars() on the URL before handing it to git clone. An attacker who controls the URL argument — the documented use case for clonefrom() in "import repository from URL" features of CI servers, git-hosting mirrors, and dependency scanners — can embed $NAME / ${NAME} tokens that are expanded server-side to the values of the hosting process's environment variables. The resulting URL, now containing the secret, is transmitted over the network to the attacker-named host. This crosses the trust boundary between an untrusted remote URL and the server's process environment, disclosing secrets such as AWSSECRETACCESSKEY or GITHUBTOKEN with no precondition beyond the ability to submit a clone URL. Details Affected versions: gitpython (PyPI) — all releases up to and including 3.1.50 (latest at time of reporting); confirmed present on the main branch.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rwj8-pgh3-r573

  2. Revision 1 · created ·

    Published from osv record GHSA-rwj8-pgh3-r573

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67322

Advisory: GitPython: Environment-variable exfiltration via os.path.expandvars() on Repo.clone_from() URL
IDs: CVE-2026-67322, GHSA-rwj8-pgh3-r573
Record: https://patchnext.com/advisories/cve-2026-67322 (revision 2, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gitpython 3.1.52. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gitpython: affected < 3.1.52; fixed in 3.1.52

## Suggested inspection (read-only)
- `python -m pip show gitpython`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gitpython.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rwj8-pgh3-r573 (OSV record GHSA-rwj8-pgh3-r573 lists affected ranges: PyPI gitpython >=0 <3.1.52 (fixed))
- Verified: https://github.com/advisories/GHSA-rwj8-pgh3-r573 (GitHub-reviewed advisory GHSA-rwj8-pgh3-r573 lists affected ranges: PyPI gitpython >=0 <3.1.52)

Commands are suggestions: review each one before running it.

Loading voting…