Axios form serializer maxDepth bypass via {} metatoken
CVE-2026-67321GHSA-hcpx-6fm6-wx23
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (axios 1.18.0, 0.33.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm axios
- Affected
- >= 0.31.1, < 0.33.0>= 1.15.1, < 1.18.0
- Fixed in
- 1.18.0, 0.33.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hcpx-6fm6-wx23 lists affected ranges: npm axios >=0.31.1 =1.15.1 <1.18.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hcpx-6fm6-wx23 lists affected ranges: npm axios >=0.31.1 =1.15.1 <1.18.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-67321: 0.53% estimated exploitation activity in the next 30 days; percentile 45.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Axios versions in the fixed lines for GHSA-62hf-57xw-28j9 still contain an incomplete depth-limit bypass in lib/helpers/toFormData.js. When serializing an object with a top-level key ending in {}, axios calls JSON.stringify() on that value before the formSerializer.maxDepth guard can inspect the nested structure. An attacker who can control object keys and nested values passed by an application into axios form or parameter serialization can trigger a raw RangeError: Maximum call stack size exceeded, causing a denial of service in the affected request path. Impact The impact is availability only. No confidentiality or integrity impact was confirmed. Server-side applications are the primary concern when they accept user-controlled input and pass it into axios as data or params for multipart/form-data, application/x-www-form-urlencoded, or default parameter serialization. Browser impact is limited to the page or request context unless the application builds a broader failure…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hcpx-6fm6-wx23
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-hcpx-6fm6-wx23
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-67321
Advisory: Axios form serializer maxDepth bypass via {} metatoken
IDs: CVE-2026-67321, GHSA-hcpx-6fm6-wx23
Record: https://patchnext.com/advisories/cve-2026-67321 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: axios 1.18.0, 0.33.0. A vendor fix does not mean a deployment is fixed.
## Affected components
- npm axios: affected >= 0.31.1, < 0.33.0; >= 1.15.1, < 1.18.0; fixed in 1.18.0, 0.33.0
## Suggested inspection (read-only)
- `npm ls axios --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on axios.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hcpx-6fm6-wx23 (OSV record GHSA-hcpx-6fm6-wx23 lists affected ranges: npm axios >=0.31.1 =1.15.1 <1.18.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hcpx-6fm6-wx23 (GitHub-reviewed advisory GHSA-hcpx-6fm6-wx23 lists affected ranges: npm axios >=0.31.1 =1.15.1 <1.18.0)
Commands are suggestions: review each one before running it.Loading voting…