Skip to content

← Actionable
High, CVSS 8.3amended

Axios Node HTTP adapter can use an inherited proxy after interceptor config cloning

CVE-2026-67320GHSA-gcfj-64vw-6mp9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (axios 1.18.0, 0.33.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm axios

    Affected
    >= 0.31.1, < 0.33.0>= 1.15.2, < 1.18.0
    Fixed in
    1.18.0, 0.33.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-67320: 0.52% estimated exploitation activity in the next 30 days; percentile 44.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Axios’ Node.js HTTP adapter can route requests through an attacker-controlled proxy when Object.prototype.proxy is polluted and request configuration is materialized as a regular object before dispatch. Recent axios releases harden merged request config by creating a null-prototype object. However, request interceptors run after that merge and may return a replacement config. A common immutable interceptor pattern such as {...config} or Object.assign({}, config) converts the hardened config back into a normal object. Axios then dispatches that object without re-hardening it, and the Node HTTP adapter reads config.proxy through the prototype chain. Impact In a Node.js deployment using the HTTP adapter, an attacker who can trigger prototype pollution elsewhere in the process can route affected HTTP requests through an attacker-controlled proxy. The highest confirmed impact is for plaintext HTTP requests. The proxy can observe explicit Authorization headers, axios-generated…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gcfj-64vw-6mp9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-gcfj-64vw-6mp9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67320

Advisory: Axios Node HTTP adapter can use an inherited proxy after interceptor config cloning
IDs: CVE-2026-67320, GHSA-gcfj-64vw-6mp9
Record: https://patchnext.com/advisories/cve-2026-67320 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: axios 1.18.0, 0.33.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm axios: affected >= 0.31.1, < 0.33.0; >= 1.15.2, < 1.18.0; fixed in 1.18.0, 0.33.0

## Suggested inspection (read-only)
- `npm ls axios --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on axios.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gcfj-64vw-6mp9 (OSV record GHSA-gcfj-64vw-6mp9 lists affected ranges: npm axios >=0.31.1 =1.15.2 <1.18.0 (fixed))
- Verified: https://github.com/advisories/GHSA-gcfj-64vw-6mp9 (GitHub-reviewed advisory GHSA-gcfj-64vw-6mp9 lists affected ranges: npm axios >=0.31.1 =1.15.2 <1.18.0)

Commands are suggestions: review each one before running it.

Loading voting…