Skip to content

← Actionable
Medium, CVSS 6.3amended

Axios: Fetch adapter ReadableStream uploads bypass maxBodyLength

CVE-2026-67317GHSA-jqh4-m9w3-8hp9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (axios 1.18.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm axios

    Affected
    >= 1.7.0, < 1.18.0
    Fixed in
    1.18.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L · score source
EPSS
  • CVE-2026-67317: 0.60% estimated exploitation activity in the next 30 days; percentile 48.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary axios’ fetch adapter does not enforce maxBodyLength for live WHATWG ReadableStream request bodies whose size cannot be determined before dispatch. Applications that use adapter: "fetch" and rely on maxBodyLength to cap untrusted upload/proxy streams can send the full stream even when it exceeds the configured limit. This affects fetch-adapter usage in edge runtimes where fetch is selected, and in Node.js or browser environments where the fetch adapter is explicitly selected. The HTTP adapter’s stream upload path is not affected. Impact An attacker who can supply or influence a streamed request body can bypass the caller’s configured upload-size limit. Practical impact is unexpected outbound network egress, request-level resource consumption, and possible exhaustion of upstream API quotas or bandwidth. This does not expose response data, execute code, or modify axios configuration. Exploitability depends on an application passing attacker-controlled, unknown-length stream data…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jqh4-m9w3-8hp9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-jqh4-m9w3-8hp9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67317

Advisory: Axios: Fetch adapter `ReadableStream` uploads bypass `maxBodyLength`
IDs: CVE-2026-67317, GHSA-jqh4-m9w3-8hp9
Record: https://patchnext.com/advisories/cve-2026-67317 (revision 3, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: axios 1.18.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm axios: affected >= 1.7.0, < 1.18.0; fixed in 1.18.0

## Suggested inspection (read-only)
- `npm ls axios --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on axios.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jqh4-m9w3-8hp9 (OSV record GHSA-jqh4-m9w3-8hp9 lists affected ranges: npm axios >=1.7.0 <1.18.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jqh4-m9w3-8hp9 (GitHub-reviewed advisory GHSA-jqh4-m9w3-8hp9 lists affected ranges: npm axios >=1.7.0 <1.18.0)

Commands are suggestions: review each one before running it.

Loading voting…