Axios: Deep formToJSON Key Recursion Can Cause Denial of Service
CVE-2026-67312GHSA-pmv8-rq9r-6j72
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (axios 1.18.0, 0.33.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm axios
- Affected
- >= 0.28.0, < 0.33.0>= 1.0.0, < 1.18.0
- Fixed in
- 1.18.0, 0.33.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pmv8-rq9r-6j72 lists affected ranges: npm axios >=0.28.0 =1.0.0 <1.18.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pmv8-rq9r-6j72 lists affected ranges: npm axios >=0.28.0 =1.0.0 <1.18.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-67312: 0.52% estimated exploitation activity in the next 30 days; percentile 44.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Axios versions starting with 0.28.0 contain uncontrolled recursion in formDataToJSON, which is exposed as axios.formToJSON() and used internally when axios serialises FormData with Content-Type: application/json. If an application passes attacker-controlled FormData field names to this functionality, a field name with thousands of nested bracket segments can exhaust the JavaScript call stack and cause denial of service for that request or, in applications without appropriate error handling, process termination. Impact Applications are affected only when untrusted users can control FormData key names that are converted through axios. Affected paths include direct use of axios.formToJSON() on untrusted FormData and axios requests in which attacker-controlled FormData is sent with Content-Type: application/json. The observed failure is RangeError: Maximum call stack size exceeded. In local testing, this error is catchable, so process-wide crash depends on the consuming…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pmv8-rq9r-6j72
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pmv8-rq9r-6j72
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-67312 Advisory: Axios: Deep formToJSON Key Recursion Can Cause Denial of Service IDs: CVE-2026-67312, GHSA-pmv8-rq9r-6j72 Record: https://patchnext.com/advisories/cve-2026-67312 (revision 3, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: axios 1.18.0, 0.33.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm axios: affected >= 0.28.0, < 0.33.0; >= 1.0.0, < 1.18.0; fixed in 1.18.0, 0.33.0 ## Suggested inspection (read-only) - `npm ls axios --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on axios. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pmv8-rq9r-6j72 (OSV record GHSA-pmv8-rq9r-6j72 lists affected ranges: npm axios >=0.28.0 =1.0.0 <1.18.0 (fixed)) - Verified: https://github.com/advisories/GHSA-pmv8-rq9r-6j72 (GitHub-reviewed advisory GHSA-pmv8-rq9r-6j72 lists affected ranges: npm axios >=0.28.0 =1.0.0 <1.18.0) Commands are suggestions: review each one before running it.
Loading voting…