Skip to content

← Actionable
High, CVSS 7.3

Apache Airflow scheduler unsafely deserializes human-in-the-loop task next_kwargs

CVE-2026-67260GHSA-q4c3-7575-55j2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 3.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-67260: 0.78% estimated exploitation activity in the next 30 days; percentile 55.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Airflow 3.3.0 moved human-in-the-loop tasks from the triggerer to a new awaitinginput task state swept by the scheduler. That sweep deserializes the task instance's nextkwargs without an allow-list, so a Dag author — who controls that value through the task execution API — can cause an arbitrary module import and object instantiation inside the scheduler process, or terminate the scheduler job. No non-default configuration is required: the sweep runs unconditionally every 15 seconds, and the default alloweddeserializationclasses setting does not cover this code path. Versions before 3.3.0 are not affected, because human-in-the-loop tasks deferred onto the triggerer instead. This is a different code path from CVE-2026-58076, which covers the same unguarded exception-node deserialization reached elsewhere — deployments that applied that fix must upgrade for this issue as well. Users are advised to upgrade to apache-airflow 3.3.1 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q4c3-7575-55j2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67260

Advisory: Apache Airflow scheduler unsafely deserializes human-in-the-loop task next_kwargs
IDs: CVE-2026-67260, GHSA-q4c3-7575-55j2
Record: https://patchnext.com/advisories/cve-2026-67260 (revision 1, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow 3.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow: affected >= 3.3.0, < 3.3.1; fixed in 3.3.1

## Suggested inspection (read-only)
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q4c3-7575-55j2 (GitHub-reviewed advisory GHSA-q4c3-7575-55j2 lists affected ranges: PyPI apache-airflow >=3.3.0 <3.3.1)

Commands are suggestions: review each one before running it.

Loading voting…