Mattermost doesn't enforce PermissionInviteUser when setting AllowOpenInvite or AllowedDomains during team creation
CVE-2026-6689GHSA-c28q-m4gf-vg4q
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- >= 8.0.0-20250731163400-5b955468ea1e, < 8.0.0-20260501144115-7d6816abdfd1
- Fixed in
- 8.0.0-20260501144115-7d6816abdfd1
Go github.com/mattermost/mattermost-server/v6
- Affected
- every version
- Fixed in
- no fixed version recorded
Go github.com/mattermost/mattermost-server
- Affected
- >= 11.6.0, <= 11.6.0>= 11.5.0, <= 11.5.4>= 10.11.0, <= 10.11.15
- Fixed in
- 10.11.17, 11.5.5, 11.6.1
Go github.com/mattermost/mattermost-server/v5
- Affected
- every version
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6283 lists affected ranges: Go github.com/mattermost/mattermost-server >=10.11.0+incompatible =11.5.0+incompatible =11.6.0+incompatible =0; Go github.com/mattermost/mattermost-server/v6 >=0; Go github.com/mattermost/mattermost/server/v8 >=8.0.0-20250731163400-5b955468ea1e <8.0.0-20260501144115-7d6816abdfd1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c28q-m4gf-vg4q lists affected ranges: Go github.com/mattermost/mattermost-server >=11.6.0 =11.5.0 =10.11.0 =8.0.0-20250731163400-5b955468ea1e <8.0.0-20260501144115-7d6816abdfd1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-6689: 0.15% estimated exploitation activity in the next 30 days; percentile 4.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 Fail to enforce PermissionInviteUser when setting AllowOpenInvite or AllowedDomains during team creation (the check was only applied on update/patch), which allows an authenticated user holding PermissionCreateTeam but not PermissionInviteUser on the resulting team to configure invite-controlled team settings (make the team publicly joinable via open invite and/or constrain membership via allowed domains) that they are not permitted to set on an existing team via POST /api/v4/teams with allowopeninvite: true and/or a non-empty alloweddomains in the request body.. Mattermost Advisory ID: MMSA-2026-00655
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c28q-m4gf-vg4q
- Revision 1 · created ·
Published from osv record GO-2026-6283
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-6689 Advisory: Mattermost doesn't enforce PermissionInviteUser when setting AllowOpenInvite or AllowedDomains during team creation IDs: CVE-2026-6689, GHSA-c28q-m4gf-vg4q Record: https://patchnext.com/advisories/cve-2026-6689 (revision 2, source checked 26 Oct 2026, 15:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.0.0-20260501144115-7d6816abdfd1; github.com/mattermost/mattermost-server 11.6.1, 11.5.5, 10.11.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected >= 8.0.0-20250731163400-5b955468ea1e, < 8.0.0-20260501144115-7d6816abdfd1; fixed in 8.0.0-20260501144115-7d6816abdfd1 - Go github.com/mattermost/mattermost-server/v6: affected every version - Go github.com/mattermost/mattermost-server: affected >= 11.6.0, <= 11.6.0; >= 11.5.0, <= 11.5.4; >= 10.11.0, <= 10.11.15; fixed in 10.11.17, 11.5.5, 11.6.1 - Go github.com/mattermost/mattermost-server/v5: affected every version ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server/v6: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server/v5: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server/v6, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6283 (OSV record GO-2026-6283 lists affected ranges: Go github.com/mattermost/mattermost-server >=10.11.0+incompatible =11.5.0+incompatible =11.6.0+incompatible =0; Go github.com/mattermost/mattermost-server/v6 >=0; Go github.com/mattermost/mattermost/server/v8 >=8.0.0-20250731163400-5b955468ea1e <8.0.0-20260501144115-7d6816abdfd1 (fixed)) - Verified: https://github.com/advisories/GHSA-c28q-m4gf-vg4q (GitHub-reviewed advisory GHSA-c28q-m4gf-vg4q lists affected ranges: Go github.com/mattermost/mattermost-server >=11.6.0 =11.5.0 =10.11.0 =8.0.0-20250731163400-5b955468ea1e <8.0.0-20260501144115-7d6816abdfd1) Commands are suggestions: review each one before running it.
Loading voting…