Skip to content

← Actionable
Critical, CVSS 9.5amended

Active Storage has possible arbitrary file read and remote code execution in Active Storage variant processing

CVE-2026-66066GHSA-xr9x-r78c-5hrm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (activestorage 8.1.3.1, 8.0.5.1, 7.2.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems activestorage

    Affected
    < 7.2.3.2>= 8.0.0.beta1, < 8.0.5.1>= 8.1.0.beta1, < 8.1.3.1
    Fixed in
    7.2.3.2, 8.0.5.1, 8.1.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-66066: 30.07% estimated exploitation activity in the next 30 days; percentile 98.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In its default configuration, a Rails application that displays image variants may allow an unauthenticated attacker to read arbitrary files from the server, including the process environment. That environment typically holds secretkeybase and often credentials for external systems, which may in turn allow escalation to remote code execution or lateral movement to those systems. Details libvips reads and writes file formats through "loaders" and "savers" (or more generally "operations"), many of which are backed by third-party libraries. It marks some of these operations as "unfuzzed", meaning they are unsafe for untrusted content, and several handle formats unrelated to web images. Active Storage did not disable the unfuzzed operations, so an attacker who can upload a crafted file and cause a variant to be generated from it may be able to invoke one. We are aware of a mechanism by which an attacker, by uploading a crafted file, is able to cause disclosure of the contents of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xr9x-r78c-5hrm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xr9x-r78c-5hrm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-66066

Advisory: Active Storage has possible arbitrary file read and remote code execution in Active Storage variant processing
IDs: CVE-2026-66066, GHSA-xr9x-r78c-5hrm
Record: https://patchnext.com/advisories/cve-2026-66066 (revision 3, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: activestorage 8.1.3.1, 8.0.5.1, 7.2.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems activestorage: affected < 7.2.3.2; >= 8.0.0.beta1, < 8.0.5.1; >= 8.1.0.beta1, < 8.1.3.1; fixed in 7.2.3.2, 8.0.5.1, 8.1.3.1

## Suggested inspection (read-only)
- RubyGems activestorage: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on activestorage.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xr9x-r78c-5hrm (OSV record GHSA-xr9x-r78c-5hrm lists affected ranges: RubyGems activestorage >=0 =8.0.0.beta1 =8.1.0.beta1 <8.1.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-xr9x-r78c-5hrm (GitHub-reviewed advisory GHSA-xr9x-r78c-5hrm lists affected ranges: RubyGems activestorage >=0 =8.0.0.beta1 =8.1.0.beta1 <8.1.3.1)

Commands are suggestions: review each one before running it.

Loading voting…