BlenderMCP path traversal in download_polyhaven_asset allows arbitrary file writes
CVE-2026-66004GHSA-4h8q-hh2j-755w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (blender-mcp 1.6.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI blender-mcp
- Affected
- < 1.6.5
- Fixed in
- 1.6.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4h8q-hh2j-755w lists affected ranges: PyPI blender-mcp >=0 <1.6.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4h8q-hh2j-755w lists affected ranges: PyPI blender-mcp >=0 <1.6.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-66004: 0.30% estimated exploitation activity in the next 30 days; percentile 22.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
BlenderMCP before commit 30a3308 contains a path traversal vulnerability in the downloadpolyhavenasset method that allows attackers to write arbitrary files by injecting traversal sequences in API response include keys. Attackers performing MITM attacks or prompt injection can supply malicious paths like '../../.bashrc' to overwrite sensitive files and achieve persistent code execution.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4h8q-hh2j-755w
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4h8q-hh2j-755w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-66004 Advisory: BlenderMCP path traversal in download_polyhaven_asset allows arbitrary file writes IDs: CVE-2026-66004, GHSA-4h8q-hh2j-755w Record: https://patchnext.com/advisories/cve-2026-66004 (revision 3, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: blender-mcp 1.6.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI blender-mcp: affected < 1.6.5; fixed in 1.6.5 ## Suggested inspection (read-only) - `python -m pip show blender-mcp`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on blender-mcp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4h8q-hh2j-755w (OSV record GHSA-4h8q-hh2j-755w lists affected ranges: PyPI blender-mcp >=0 <1.6.5 (fixed)) - Verified: https://github.com/advisories/GHSA-4h8q-hh2j-755w (GitHub-reviewed advisory GHSA-4h8q-hh2j-755w lists affected ranges: PyPI blender-mcp >=0 <1.6.5) Commands are suggestions: review each one before running it.
Loading voting…