PHPCSUtils: Remote code execution via eval() in AbstractArrayDeclarationSniff::getActualArrayKey()
CVE-2026-65954GHSA-r6hr-vr92-vv28
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpcsstandards/phpcsutils 1.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpcsstandards/phpcsutils
- Affected
- >= 1.0.0-alpha1, < 1.2.3
- Fixed in
- 1.2.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r6hr-vr92-vv28 lists affected ranges: Packagist phpcsstandards/phpcsutils >=1.0.0-alpha1 <1.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r6hr-vr92-vv28 lists affected ranges: Packagist phpcsstandards/phpcsutils >=1.0.0-alpha1 <1.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-65954: 0.15% estimated exploitation activity in the next 30 days; percentile 4.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact PHPCSUtils versions 1.0.0-alpha1 through 1.2.2 contain an arbitrary code execution vulnerability in PHPCSUtils\AbstractSniffs\AbstractArrayDeclarationSniff::getActualArrayKey(). The vulnerable method is reached by any sniff that extends AbstractArrayDeclarationSniff and calls getActualArrayKey(). Running PHPCS over untrusted PHP code through such a sniff, for example, in a CI pipeline that lints pull requests, or on a developer machine reviewing third-party code, could lead to arbitrary command execution on the scanning host. The vulnerability happens when the method determines the value of an array key using eval(). A maliciously crafted array key such as 'system'('id') would be executed when the code was scanned. Known attack vectors Known code paths that reach the vulnerable method include the following PHPCSExtra sniffs: - Universal.Arrays.DuplicateArrayKey - Universal.Arrays.MixedArrayKeyTypes Other packages that call AbstractArrayDeclarationSniff::getActualArrayKey() may…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r6hr-vr92-vv28
- Revision 1 · created ·
Published from osv record GHSA-r6hr-vr92-vv28
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-65954 Advisory: PHPCSUtils: Remote code execution via eval() in AbstractArrayDeclarationSniff::getActualArrayKey() IDs: CVE-2026-65954, GHSA-r6hr-vr92-vv28 Record: https://patchnext.com/advisories/cve-2026-65954 (revision 2, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpcsstandards/phpcsutils 1.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpcsstandards/phpcsutils: affected >= 1.0.0-alpha1, < 1.2.3; fixed in 1.2.3 ## Suggested inspection (read-only) - Packagist phpcsstandards/phpcsutils: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpcsstandards/phpcsutils. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r6hr-vr92-vv28 (OSV record GHSA-r6hr-vr92-vv28 lists affected ranges: Packagist phpcsstandards/phpcsutils >=1.0.0-alpha1 <1.2.3 (fixed)) - Verified: https://github.com/advisories/GHSA-r6hr-vr92-vv28 (GitHub-reviewed advisory GHSA-r6hr-vr92-vv28 lists affected ranges: Packagist phpcsstandards/phpcsutils >=1.0.0-alpha1 <1.2.3) Commands are suggestions: review each one before running it.
Loading voting…