Skip to content

← Actionable
Medium, CVSS 6.9amended

DOMPurify is vulnerable to mutation-XSS via Re-Contextualization

CVE-2026-65914GHSA-h8r8-wccr-v5f2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dompurify 3.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-65914: 0.31% estimated exploitation activity in the next 30 days; percentile 23.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description A mutation-XSS (mXSS) condition was confirmed when sanitized HTML is reinserted into a new parsing context using innerHTML and special wrappers. The vulnerable wrappers confirmed in browser behavior are script, xmp, iframe, noembed, noframes, and noscript. The payload remains seemingly benign after DOMPurify.sanitize(), but mutates during the second parse into executable markup with an event handler, enabling JavaScript execution in the client (alert(1) in the PoC). Vulnerability The root cause is context switching after sanitization: sanitized output is treated as trusted and concatenated into a wrapper string (for example, <xmp ... </xmp or other special wrappers) before being reparsed by the browser. In this flow, attacker-controlled text inside an attribute (for example </xmp or equivalent closing sequences for each wrapper) closes the special parsing context early and reintroduces attacker markup (<img ... onerror=...) outside the original attribute context.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-h8r8-wccr-v5f2

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-h8r8-wccr-v5f2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-65914

Advisory: DOMPurify is vulnerable to mutation-XSS via Re-Contextualization
IDs: CVE-2026-65914, GHSA-h8r8-wccr-v5f2
Record: https://patchnext.com/advisories/cve-2026-65914 (revision 3, source checked 26 Oct 2026, 12:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dompurify 3.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm dompurify: affected < 3.3.2; fixed in 3.3.2

## Suggested inspection (read-only)
- `npm ls dompurify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dompurify.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h8r8-wccr-v5f2 (OSV record GHSA-h8r8-wccr-v5f2 lists affected ranges: npm dompurify >=0 <3.3.2 (fixed))
- Verified: https://github.com/advisories/GHSA-h8r8-wccr-v5f2 (GitHub-reviewed advisory GHSA-h8r8-wccr-v5f2 lists affected ranges: npm dompurify >=0 <3.3.2)

Commands are suggestions: review each one before running it.

Loading voting…