Skip to content

← Actionable
High, CVSS 8.2

Plate: SSRF with response disclosure in DOCX image embedding

CVE-2026-65842GHSA-4q39-2jhr-7qx8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@platejs/docx-io 53.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
EPSS
  • CVE-2026-65842: 0.52% estimated exploitation activity in the next 30 days; percentile 44.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary @platejs/docx-io can fetch remote image URLs while converting HTML to DOCX. When an application converts attacker-controlled HTML in a server-side or privileged environment, this can cause the application environment to make unintended outbound requests and include fetched image data in the generated DOCX. Impact Applications are affected when they use @platejs/docx-io to convert untrusted HTML that may contain remote image references, especially in server-side conversion workflows or environments with access to internal network resources. Affected package: - @platejs/docx-io versions < 53.3.2 Patched versions Upgrade to @platejs/docx-io version 53.3.2 or later. Workarounds If you cannot upgrade immediately, do not pass untrusted HTML with remote image URLs to DOCX export. Sanitize untrusted HTML to remove remote image references, convert trusted images to data URIs before conversion, or run conversion in an environment with restricted outbound network access. Credits Thanks…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4q39-2jhr-7qx8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-65842

Advisory: Plate: SSRF with response disclosure in DOCX image embedding
IDs: CVE-2026-65842, GHSA-4q39-2jhr-7qx8
Record: https://patchnext.com/advisories/cve-2026-65842 (revision 1, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @platejs/docx-io 53.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @platejs/docx-io: affected < 53.3.2; fixed in 53.3.2

## Suggested inspection (read-only)
- `npm ls @platejs/docx-io --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @platejs/docx-io.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4q39-2jhr-7qx8 (GitHub-reviewed advisory GHSA-4q39-2jhr-7qx8 lists affected ranges: npm @platejs/docx-io >=0 <53.3.2)

Commands are suggestions: review each one before running it.

Loading voting…