MPXJ: Potential Path Traversal Vulnerability in Primavera P3 PRX and SureTrak STX readers
CVE-2026-65829GHSA-7952-gx68-cjqr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mpxj.net 16.5.0; net.sf.mpxj 16.5.0; mpxj 16.5.0; net.sf.mpxj:mpxj 16.5.0; net.sf.mpxj-for-vb 16.5.0; 2 more packages under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet mpxj.net
- Affected
- >= 7.3.0, < 16.5.0
- Fixed in
- 16.5.0
NuGet net.sf.mpxj
- Affected
- >= 7.3.0, < 16.5.0
- Fixed in
- 16.5.0
RubyGems mpxj
- Affected
- >= 7.3.0, < 16.5.0
- Fixed in
- 16.5.0
Maven net.sf.mpxj:mpxj
- Affected
- >= 7.3.0, < 16.5.0
- Fixed in
- 16.5.0
NuGet net.sf.mpxj-for-vb
- Affected
- >= 7.3.0, < 16.5.0
- Fixed in
- 16.5.0
PyPI mpxj
- Affected
- >= 7.3.0, < 16.5.0
- Fixed in
- 16.5.0
NuGet net.sf.mpxj-for-csharp
- Affected
- >= 7.3.0, < 16.5.0
- Fixed in
- 16.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7952-gx68-cjqr lists affected ranges: PyPI mpxj >=7.3.0 <16.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7952-gx68-cjqr lists affected ranges: NuGet mpxj.net >=7.3.0 =7.3.0 =7.3.0 =7.3.0 =7.3.0 =7.3.0 =7.3.0 <16.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7952-gx68-cjqr lists affected ranges: NuGet mpxj.net >=7.3.0 =7.3.0 =7.3.0 =7.3.0 =7.3.0 =7.3.0 =7.3.0 <16.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-65829: 0.43% estimated exploitation activity in the next 30 days; percentile 37.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When reading a suitably crafted PRX or STX file, MPXJ can be made to write files to arbitrary locations in the file system. Patches This issue is addressed in MPXJ version 16.5.0. Workarounds Do not read PRX or STX files from untrusted sources.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7952-gx68-cjqr
- Revision 2 · amended ·
Amended from osv record GHSA-7952-gx68-cjqr
- Revision 1 · created ·
Published from ghsa record GHSA-7952-gx68-cjqr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-65829 Advisory: MPXJ: Potential Path Traversal Vulnerability in Primavera P3 PRX and SureTrak STX readers IDs: CVE-2026-65829, GHSA-7952-gx68-cjqr Record: https://patchnext.com/advisories/cve-2026-65829 (revision 3, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mpxj.net 16.5.0; net.sf.mpxj 16.5.0; mpxj 16.5.0; net.sf.mpxj:mpxj 16.5.0; net.sf.mpxj-for-vb 16.5.0; mpxj 16.5.0; net.sf.mpxj-for-csharp 16.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet mpxj.net: affected >= 7.3.0, < 16.5.0; fixed in 16.5.0 - NuGet net.sf.mpxj: affected >= 7.3.0, < 16.5.0; fixed in 16.5.0 - RubyGems mpxj: affected >= 7.3.0, < 16.5.0; fixed in 16.5.0 - Maven net.sf.mpxj:mpxj: affected >= 7.3.0, < 16.5.0; fixed in 16.5.0 - NuGet net.sf.mpxj-for-vb: affected >= 7.3.0, < 16.5.0; fixed in 16.5.0 - PyPI mpxj: affected >= 7.3.0, < 16.5.0; fixed in 16.5.0 - NuGet net.sf.mpxj-for-csharp: affected >= 7.3.0, < 16.5.0; fixed in 16.5.0 ## Suggested inspection (read-only) - NuGet mpxj.net: check the installed version with your package manager. - NuGet net.sf.mpxj: check the installed version with your package manager. - RubyGems mpxj: check the installed version with your package manager. - Maven net.sf.mpxj:mpxj: check the installed version with your package manager. - NuGet net.sf.mpxj-for-vb: check the installed version with your package manager. - `python -m pip show mpxj`: prints the installed version. Run with the environment that serves production active. - NuGet net.sf.mpxj-for-csharp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mpxj.net, net.sf.mpxj, mpxj, net.sf.mpxj:mpxj, net.sf.mpxj-for-vb, net.sf.mpxj-for-csharp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7952-gx68-cjqr (GitHub-reviewed advisory GHSA-7952-gx68-cjqr lists affected ranges: PyPI mpxj >=7.3.0 <16.5.0) - Verified: https://osv.dev/vulnerability/GHSA-7952-gx68-cjqr (OSV record GHSA-7952-gx68-cjqr lists affected ranges: NuGet mpxj.net >=7.3.0 =7.3.0 =7.3.0 =7.3.0 =7.3.0 =7.3.0 =7.3.0 <16.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7952-gx68-cjqr (GitHub-reviewed advisory GHSA-7952-gx68-cjqr lists affected ranges: NuGet mpxj.net >=7.3.0 =7.3.0 =7.3.0 =7.3.0 =7.3.0 =7.3.0 =7.3.0 <16.5.0) Commands are suggestions: review each one before running it.
Loading voting…