Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation
CVE-2026-65637GHSA-f525-44xv-f2qj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-coyote 11.0.25, 10.1.59, 9.0.121; org.apache.tomcat.embed:tomcat-embed-core 11.0.25, 10.1.59, 9.0.121; tomcat 11.0.25, 10.1.58, 9.0.121), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-coyote
- Affected
- >= 11.0.20, < 11.0.25>= 10.1.53, < 10.1.59>= 9.0.115, < 9.0.121
- Fixed in
- 10.1.59, 11.0.25, 9.0.121
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 11.0.20, < 11.0.25>= 10.1.53, < 10.1.59>= 9.0.115, < 9.0.121
- Fixed in
- 10.1.59, 11.0.25, 9.0.121
Bitnami tomcat
- Affected
- >= 9.0.115, < 9.0.121>= 10.1.53, < 10.1.58>= 11.0.20, < 11.0.25
- Fixed in
- 11.0.25, 9.0.121, 10.1.58
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f525-44xv-f2qj lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=11.0.20 =10.1.53 =9.0.115 =11.0.20 =10.1.53 =9.0.115 <9.0.121
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f525-44xv-f2qj lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=11.0.20 =10.1.53 =9.0.115 =11.0.20 =10.1.53 =9.0.115 <9.0.121 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-tomcat-2026-65637 lists affected ranges: Bitnami tomcat >=9.0.115 =10.1.53 =11.0.20 <11.0.25 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-65637: 0.75% estimated exploitation activity in the next 30 days; percentile 55.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.59 or 9.0.121, which fix the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record BIT-tomcat-2026-65637
- Revision 2 · amended ·
Amended from osv record GHSA-f525-44xv-f2qj
- Revision 1 · created ·
Published from ghsa record GHSA-f525-44xv-f2qj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-65637 Advisory: Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation IDs: CVE-2026-65637, GHSA-f525-44xv-f2qj Record: https://patchnext.com/advisories/cve-2026-65637 (revision 3, source checked 28 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-coyote 11.0.25, 10.1.59, 9.0.121; org.apache.tomcat.embed:tomcat-embed-core 11.0.25, 10.1.59, 9.0.121; tomcat 11.0.25, 10.1.58, 9.0.121. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-coyote: affected >= 11.0.20, < 11.0.25; >= 10.1.53, < 10.1.59; >= 9.0.115, < 9.0.121; fixed in 10.1.59, 11.0.25, 9.0.121 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.20, < 11.0.25; >= 10.1.53, < 10.1.59; >= 9.0.115, < 9.0.121; fixed in 10.1.59, 11.0.25, 9.0.121 - Bitnami tomcat: affected >= 9.0.115, < 9.0.121; >= 10.1.53, < 10.1.58; >= 11.0.20, < 11.0.25; fixed in 11.0.25, 9.0.121, 10.1.58 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. - Bitnami tomcat: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core, tomcat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f525-44xv-f2qj (GitHub-reviewed advisory GHSA-f525-44xv-f2qj lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=11.0.20 =10.1.53 =9.0.115 =11.0.20 =10.1.53 =9.0.115 <9.0.121) - Verified: https://osv.dev/vulnerability/GHSA-f525-44xv-f2qj (OSV record GHSA-f525-44xv-f2qj lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=11.0.20 =10.1.53 =9.0.115 =11.0.20 =10.1.53 =9.0.115 <9.0.121 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-tomcat-2026-65637 (OSV record BIT-tomcat-2026-65637 lists affected ranges: Bitnami tomcat >=9.0.115 =10.1.53 =11.0.20 <11.0.25 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…