Grav: FlexDirectory::dynamicDataField() executes arbitrary callables from blueprint data with no validation
CVE-2026-65608GHSA-c4wf-2xxc-68qm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 2.0.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getgrav/grav
- Affected
- >= 1.7.0, < 2.0.9
- Fixed in
- 2.0.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c4wf-2xxc-68qm lists affected ranges: Packagist getgrav/grav >=1.7.0 <2.0.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c4wf-2xxc-68qm lists affected ranges: Packagist getgrav/grav >=1.7.0 <2.0.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-65608: 1.12% estimated exploitation activity in the next 30 days; percentile 66.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A missing validation check in Grav's Flex framework lets an account holding nothing but an ordinary object-create permission on a single Flex directory execute arbitrary shell commands on the server. Any authenticated user with create or update rights on a Flex-based directory (Flex Users, Flex Pages, Flex Objects, or any custom Flex type) can trigger it the moment a blueprint field anywhere in that directory carries a data-@: directive, since the code that resolves those directives calls calluserfuncarray() on attacker-influenced input with no restriction at all. This is a bypass of GHSA-fj2p-qj2f-74v5, already patched in 2.0.7. That fix added real validation to Blueprint::dynamicData(), but Grav's Flex system routes the same directive through a separate, unprotected method, FlexDirectory::dynamicDataField(), which never received the same fix. Details Grav blueprints support action-property@: directives, YAML keys that tell the blueprint engine to compute a field's value…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-c4wf-2xxc-68qm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-c4wf-2xxc-68qm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-65608 Advisory: Grav: FlexDirectory::dynamicDataField() executes arbitrary callables from blueprint data with no validation IDs: CVE-2026-65608, GHSA-c4wf-2xxc-68qm Record: https://patchnext.com/advisories/cve-2026-65608 (revision 3, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 2.0.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getgrav/grav: affected >= 1.7.0, < 2.0.9; fixed in 2.0.9 ## Suggested inspection (read-only) - Packagist getgrav/grav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getgrav/grav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c4wf-2xxc-68qm (OSV record GHSA-c4wf-2xxc-68qm lists affected ranges: Packagist getgrav/grav >=1.7.0 <2.0.9 (fixed)) - Verified: https://github.com/advisories/GHSA-c4wf-2xxc-68qm (GitHub-reviewed advisory GHSA-c4wf-2xxc-68qm lists affected ranges: Packagist getgrav/grav >=1.7.0 <2.0.9) Commands are suggestions: review each one before running it.
Loading voting…