n8n: Race Condition in Git Clone Node Allows Authenticated Users to Achieve Remote Code Execution
CVE-2026-65598GHSA-g3r5-9h93-4j2c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.30.1, 2.29.8, 1.123.64), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 1.123.64>= 2.30.0, < 2.30.1>= 2.0.0-rc.0, < 2.29.8
- Fixed in
- 2.29.8, 2.30.1, 1.123.64
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g3r5-9h93-4j2c lists affected ranges: npm n8n >=0 =2.30.0 =2.0.0-rc.0 <2.29.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g3r5-9h93-4j2c lists affected ranges: npm n8n >=0 =2.30.0 =2.0.0-rc.0 <2.29.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:L/SA:L · score source
- EPSS
- CVE-2026-65598: 0.34% estimated exploitation activity in the next 30 days; percentile 26.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
- CVE-2026-71539: 0.30% estimated exploitation activity in the next 30 days; percentile 23.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A TOCTOU race condition in the Git node's clone operation lets an authenticated user bypass its path restrictions by swapping a directory for a symlink after the path is validated but before the clone runs. This plants a crafted repository in the community node directory, which n8n loads as a custom node on the next restart, and since nodes execute JavaScript, this yields arbitrary code execution on the server. Both self-hosted and cloud instances are affected, where authenticated users can create and run workflows using the Git node. Patches Users should upgrade to the patched version once available to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict n8n instance access to fully trusted users only. - Disable the Git node by adding n8n-nodes-base.git to the NODESEXCLUDE environment variable. - Restrict network egress from the n8n instance to prevent connections to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-g3r5-9h93-4j2c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-g3r5-9h93-4j2c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-65598 Advisory: n8n: Race Condition in Git Clone Node Allows Authenticated Users to Achieve Remote Code Execution IDs: CVE-2026-65598, GHSA-g3r5-9h93-4j2c Record: https://patchnext.com/advisories/cve-2026-65598 (revision 3, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.30.1, 2.29.8, 1.123.64. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 1.123.64; >= 2.30.0, < 2.30.1; >= 2.0.0-rc.0, < 2.29.8; fixed in 2.29.8, 2.30.1, 1.123.64 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g3r5-9h93-4j2c (OSV record GHSA-g3r5-9h93-4j2c lists affected ranges: npm n8n >=0 =2.30.0 =2.0.0-rc.0 <2.29.8 (fixed)) - Verified: https://github.com/advisories/GHSA-g3r5-9h93-4j2c (GitHub-reviewed advisory GHSA-g3r5-9h93-4j2c lists affected ranges: npm n8n >=0 =2.30.0 =2.0.0-rc.0 <2.29.8) Commands are suggestions: review each one before running it.
Loading voting…