n8n: Member-Level Users Can Execute Other Users' MCP Server Trigger Workflows via Missing OAuth Authorization Check
CVE-2026-65594GHSA-q5xf-xhwf-cwqf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.30.1, 2.29.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- >= 2.30.0, < 2.30.1< 2.29.8
- Fixed in
- 2.29.8, 2.30.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q5xf-xhwf-cwqf lists affected ranges: npm n8n >=2.30.0 =0 <2.29.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q5xf-xhwf-cwqf lists affected ranges: npm n8n >=2.30.0 =0 <2.29.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:H/SI:L/SA:N · score source
- EPSS
- CVE-2026-65594: 0.44% estimated exploitation activity in the next 30 days; percentile 38.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The OAuth 2.1 consent and token-issuance flow introduced in n8n 2.27.0 does not verify that the authenticated user has access to the workflow referenced as the OAuth resource. A member-level user can register an OAuth client, self-approve consent for another user's n8n OAuth2-protected MCP Server Trigger workflow, and obtain a valid token for it. The workflow runs in the owner's project context with the owner's stored credentials. The attacker sets the tool inputs and reads the outputs, which may include data from the owner's connected integrations, breaking user and project isolation. The resulting executions appear under the owner's account and are not visible to the attacker. This issue only affects instances running n8n 2.27.0 or later where at least one active workflow uses an MCP Server Trigger node configured with n8n OAuth2 authentication. Patches The issue has been fixed in n8n versions 2.29.8 and 2.30.1. Users should upgrade to one of these versions or later to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-q5xf-xhwf-cwqf
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-q5xf-xhwf-cwqf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-65594 Advisory: n8n: Member-Level Users Can Execute Other Users' MCP Server Trigger Workflows via Missing OAuth Authorization Check IDs: CVE-2026-65594, GHSA-q5xf-xhwf-cwqf Record: https://patchnext.com/advisories/cve-2026-65594 (revision 3, source checked 26 Oct 2026, 12:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.30.1, 2.29.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected >= 2.30.0, < 2.30.1; < 2.29.8; fixed in 2.29.8, 2.30.1 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q5xf-xhwf-cwqf (OSV record GHSA-q5xf-xhwf-cwqf lists affected ranges: npm n8n >=2.30.0 =0 <2.29.8 (fixed)) - Verified: https://github.com/advisories/GHSA-q5xf-xhwf-cwqf (GitHub-reviewed advisory GHSA-q5xf-xhwf-cwqf lists affected ranges: npm n8n >=2.30.0 =0 <2.29.8) Commands are suggestions: review each one before running it.
Loading voting…