n8n: computer-use Shell Sandbox Not Enforced on Linux and Windows
CVE-2026-65590GHSA-fpg6-x68q-5793
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.30.1, 2.29.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- >= 2.30.0, < 2.30.1< 2.29.8
- Fixed in
- 2.29.8, 2.30.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fpg6-x68q-5793 lists affected ranges: npm n8n >=2.30.0 =0 <2.29.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fpg6-x68q-5793 lists affected ranges: npm n8n >=2.30.0 =0 <2.29.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-65590: 0.58% estimated exploitation activity in the next 30 days; percentile 47.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The shell tool in the @n8n/computer-use package applied its sandbox restrictions only on macOS. On Linux and Windows, shell commands executed by the tool ran without any filesystem or network restrictions, allowing unrestricted access to the host filesystem and network from within the computer-use agent process. This issue only affects deployments where the @n8n/computer-use package is explicitly installed and running. It does not affect standard n8n installations. Patches The issue has been fixed in n8n versions 2.29.8 and 2.30.1. Users should upgrade to one of these versions or later to remediate the vulnerability. The fix adds sandbox enforcement on Linux via bubblewrap and disables the shell tool entirely when a working sandbox cannot be established. An explicit opt-out flag (--dangerously-disable-shell-sandbox) is available for deployments that require unsandboxed shell access and accept the associated risk. Workarounds If upgrading is not immediately possible,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-fpg6-x68q-5793
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-fpg6-x68q-5793
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-65590 Advisory: n8n: computer-use Shell Sandbox Not Enforced on Linux and Windows IDs: CVE-2026-65590, GHSA-fpg6-x68q-5793 Record: https://patchnext.com/advisories/cve-2026-65590 (revision 3, source checked 26 Oct 2026, 12:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.30.1, 2.29.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected >= 2.30.0, < 2.30.1; < 2.29.8; fixed in 2.29.8, 2.30.1 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fpg6-x68q-5793 (OSV record GHSA-fpg6-x68q-5793 lists affected ranges: npm n8n >=2.30.0 =0 <2.29.8 (fixed)) - Verified: https://github.com/advisories/GHSA-fpg6-x68q-5793 (GitHub-reviewed advisory GHSA-fpg6-x68q-5793 lists affected ranges: npm n8n >=2.30.0 =0 <2.29.8) Commands are suggestions: review each one before running it.
Loading voting…