Apache Tomcat has an Improper Access Control, Incorrect Authorization vulnerability
CVE-2026-65182GHSA-gcx9-497g-6cp6
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-catalina
- Affected
- >= 11.0.0-M1, < 11.0.25>= 10.1.0-M1, < 10.1.58>= 9.0.0-M1, < 9.0.121>= 8.5.0, <= 8.5.100>= 7.0.0, <= 7.0.109
- Fixed in
- 11.0.25, 9.0.121, 10.1.58
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 11.0.0-M1, < 11.0.25>= 10.1.0-M1, < 10.1.58>= 9.0.0-M1, < 9.0.121>= 8.5.0, <= 8.5.100>= 7.0.0, <= 7.0.109
- Fixed in
- 11.0.25, 9.0.121, 10.1.58
Maven org.apache.tomcat:tomcat
- Affected
- >= 11.0.0-M1, < 11.0.25>= 10.1.0-M1, < 10.1.58>= 9.0.0-M1, < 9.0.121>= 8.5.0, <= 8.5.100>= 7.0.0, <= 7.0.109
- Fixed in
- 11.0.25, 9.0.121, 10.1.58
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gcx9-497g-6cp6 lists affected ranges: Maven org.apache.tomcat:tomcat >=11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =7.0.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =7.0.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1…
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gcx9-497g-6cp6 lists affected ranges: Maven org.apache.tomcat:tomcat >=11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =7.0.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =7.0.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =7.0.0 <=7.0.109
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-65182: 0.65% estimated exploitation activity in the next 30 days; percentile 51.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Access Control, Incorrect Authorization vulnerability in Apache Tomcat leads to security constraint bypass if a constraint for a longer path is specified before a more restrictive constraint for a shorter sub-path. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.25, 10.1.58, 9.0.121, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gcx9-497g-6cp6
- Revision 1 · created ·
Published from osv record GHSA-gcx9-497g-6cp6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-65182 Advisory: Apache Tomcat has an Improper Access Control, Incorrect Authorization vulnerability IDs: CVE-2026-65182, GHSA-gcx9-497g-6cp6 Record: https://patchnext.com/advisories/cve-2026-65182 (revision 2, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.tomcat:tomcat-catalina 11.0.25, 10.1.58, 9.0.121; org.apache.tomcat.embed:tomcat-embed-core 11.0.25, 10.1.58, 9.0.121; org.apache.tomcat:tomcat 11.0.25, 10.1.58, 9.0.121. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-catalina: affected >= 11.0.0-M1, < 11.0.25; >= 10.1.0-M1, < 10.1.58; >= 9.0.0-M1, < 9.0.121; >= 8.5.0, <= 8.5.100; >= 7.0.0, <= 7.0.109; fixed in 11.0.25, 9.0.121, 10.1.58 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.0-M1, < 11.0.25; >= 10.1.0-M1, < 10.1.58; >= 9.0.0-M1, < 9.0.121; >= 8.5.0, <= 8.5.100; >= 7.0.0, <= 7.0.109; fixed in 11.0.25, 9.0.121, 10.1.58 - Maven org.apache.tomcat:tomcat: affected >= 11.0.0-M1, < 11.0.25; >= 10.1.0-M1, < 10.1.58; >= 9.0.0-M1, < 9.0.121; >= 8.5.0, <= 8.5.100; >= 7.0.0, <= 7.0.109; fixed in 11.0.25, 9.0.121, 10.1.58 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-catalina: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. - Maven org.apache.tomcat:tomcat: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gcx9-497g-6cp6 (OSV record GHSA-gcx9-497g-6cp6 lists affected ranges: Maven org.apache.tomcat:tomcat >=11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =7.0.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =7.0.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1…) - Verified: https://github.com/advisories/GHSA-gcx9-497g-6cp6 (GitHub-reviewed advisory GHSA-gcx9-497g-6cp6 lists affected ranges: Maven org.apache.tomcat:tomcat >=11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =7.0.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =7.0.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =7.0.0 <=7.0.109) Commands are suggestions: review each one before running it.
Loading voting…