Apache Airflow Config API exposes team-scoped sensitive configuration values
CVE-2026-65017GHSA-c56v-8w4g-3mfm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 3.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- >= 3.3.0, < 3.3.1
- Fixed in
- 3.3.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c56v-8w4g-3mfm lists affected ranges: PyPI apache-airflow >=3.3.0 <3.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-65017: 0.39% estimated exploitation activity in the next 30 days; percentile 32.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Airflow's Config API did not mask team-scoped sensitive configuration values in multi-team deployments. When an administrator has enabled multi-team mode and exposed the Config API, an authenticated Viewer holding only configuration-read access — with no prior access to the secret — could read a team-scoped Celery broker URL, including its embedded credentials, in cleartext, while the equivalent global option was correctly masked. The secrets masker matched only base section and option names and did not normalize team-prefixed sections before the sensitivity check (CWE-200). This is a distinct masker bypass from CVE-2026-48828 and CVE-2026-48892: deployments that upgraded to apache-airflow 3.3.0 to address those issues remain affected by this team-scoped variant. Users are advised to upgrade to apache-airflow 3.3.1 or later, which normalizes team-scoped sections before masking.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c56v-8w4g-3mfm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-65017 Advisory: Apache Airflow Config API exposes team-scoped sensitive configuration values IDs: CVE-2026-65017, GHSA-c56v-8w4g-3mfm Record: https://patchnext.com/advisories/cve-2026-65017 (revision 1, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 3.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected >= 3.3.0, < 3.3.1; fixed in 3.3.1 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c56v-8w4g-3mfm (GitHub-reviewed advisory GHSA-c56v-8w4g-3mfm lists affected ranges: PyPI apache-airflow >=3.3.0 <3.3.1) Commands are suggestions: review each one before running it.
Loading voting…