n8n: SSO Instance-Role Provisioning Allows Privilege Escalation to Instance Owner
CVE-2026-65016GHSA-35q8-9mj6-wjmf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.30.1, 2.29.8, 1.123.64), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 1.123.64>= 2.30.0, < 2.30.1>= 2.0.0-rc.0, < 2.29.8
- Fixed in
- 2.29.8, 2.30.1, 1.123.64
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-35q8-9mj6-wjmf lists affected ranges: npm n8n >=0 =2.30.0 =2.0.0-rc.0 <2.29.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-35q8-9mj6-wjmf lists affected ranges: npm n8n >=0 =2.30.0 =2.0.0-rc.0 <2.29.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-65016: 0.45% estimated exploitation activity in the next 30 days; percentile 38.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact n8n's Enterprise SSO instance-role provisioning maps a role claim asserted by the configured Identity Provider (IdP) to an n8n global role and applies it during authentication. The provisioning path did not prevent assignment of the global:owner role, unlike the token-exchange identity path, which explicitly rejects it. As a result, an SSO-authenticated user whose instance-role claim resolves to global:owner is provisioned as an instance owner, obtaining full administrative control over all workflows, credentials, users, and instance configuration. This is a privilege-escalation issue that is exploitable only under specific conditions. It affects instances where Enterprise SSO is configured and instance-role provisioning is enabled via the N8NSSOSCOPESPROVISIONINSTANCEROLE flag, which is disabled by default. Exploitation additionally requires the attacker to control the value of the instance-role claim issued by the IdP. As this claim is typically an administrator-managed…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-35q8-9mj6-wjmf
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-35q8-9mj6-wjmf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-65016 Advisory: n8n: SSO Instance-Role Provisioning Allows Privilege Escalation to Instance Owner IDs: CVE-2026-65016, GHSA-35q8-9mj6-wjmf Record: https://patchnext.com/advisories/cve-2026-65016 (revision 3, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.30.1, 2.29.8, 1.123.64. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 1.123.64; >= 2.30.0, < 2.30.1; >= 2.0.0-rc.0, < 2.29.8; fixed in 2.29.8, 2.30.1, 1.123.64 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-35q8-9mj6-wjmf (OSV record GHSA-35q8-9mj6-wjmf lists affected ranges: npm n8n >=0 =2.30.0 =2.0.0-rc.0 <2.29.8 (fixed)) - Verified: https://github.com/advisories/GHSA-35q8-9mj6-wjmf (GitHub-reviewed advisory GHSA-35q8-9mj6-wjmf lists affected ranges: npm n8n >=0 =2.30.0 =2.0.0-rc.0 <2.29.8) Commands are suggestions: review each one before running it.
Loading voting…