New API: Admin can reset passkeys for same-level or higher-privileged users in github.com/QuantumNous/new-api
CVE-2026-64866GHSA-p845-629j-rcj6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/QuantumNous/new-api 1.0.0-rc.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/QuantumNous/new-api
- Affected
- < 1.0.0-rc.7
- Fixed in
- 1.0.0-rc.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6244 lists affected ranges: Go github.com/QuantumNous/new-api >=0 <1.0.0-rc.7 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-64866: 0.47% estimated exploitation activity in the next 30 days; percentile 40.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
New API: Admin can reset passkeys for same-level or higher-privileged users in github.com/QuantumNous/new-api. NOTE: The source advisory for this report contains additional versions that could not be automatically mapped to standard Go module versions. (If this is causing false-positive reports from vulnerability scanners, please suggest an edit to the report.) The additional affected modules and versions are: .
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GO-2026-6244
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-64866 Advisory: New API: Admin can reset passkeys for same-level or higher-privileged users in github.com/QuantumNous/new-api IDs: CVE-2026-64866, GHSA-p845-629j-rcj6 Record: https://patchnext.com/advisories/cve-2026-64866 (revision 2, source checked 25 Oct 2026, 04:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/QuantumNous/new-api 1.0.0-rc.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/QuantumNous/new-api: affected < 1.0.0-rc.7; fixed in 1.0.0-rc.7 ## Suggested inspection (read-only) - Go github.com/QuantumNous/new-api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/QuantumNous/new-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6244 (OSV record GO-2026-6244 lists affected ranges: Go github.com/QuantumNous/new-api >=0 <1.0.0-rc.7 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…