New API: User List API Leaks Root User Access Token Leading to Privilege Escalation
CVE-2026-64859GHSA-6x2c-phff-wx57
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/QuantumNous/new-api 1.0.0-rc.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/QuantumNous/new-api
- Affected
- < 1.0.0-rc.7
- Fixed in
- 1.0.0-rc.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6x2c-phff-wx57 lists affected ranges: Go github.com/QuantumNous/new-api >=0 <1.0.0-rc.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6240 lists affected ranges: Go github.com/QuantumNous/new-api >=0 <1.0.0-rc.7 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6x2c-phff-wx57 lists affected ranges: Go github.com/QuantumNous/new-api >=0 <1.0.0-rc.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-64859: 0.63% estimated exploitation activity in the next 30 days; percentile 50.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Vulnerability Information - Product: new-api - Affected versions: versions before v1.0.0-rc.7 that serialize User.AccessToken as accesstoken; the issue was confirmed in v0.12.14 - Patched version: v1.0.0-rc.7 - Fixed commit: 0936e2504655a5cbf7bc3c388f6d3e2bb24916d3 - Type: Information Disclosure / Privilege Escalation Description In affected versions of new-api, the admin user list and user lookup APIs can return the accesstoken field for users, including the root user. An authenticated admin user can call endpoints such as GET /api/user/ to retrieve user records. Because access tokens function as bearer credentials for API authentication, leaking the root user's access token allows an admin user to authenticate as root and access root-only endpoints such as system configuration APIs. This bypasses the intended role boundary between admin users and the root user and can result in privilege escalation to full system control. Root Cause The User.AccessToken field was serialized as…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6x2c-phff-wx57
- Revision 2 · amended ·
Amended from osv record GO-2026-6240
- Revision 1 · created ·
Published from osv record GHSA-6x2c-phff-wx57
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-64859 Advisory: New API: User List API Leaks Root User Access Token Leading to Privilege Escalation IDs: CVE-2026-64859, GHSA-6x2c-phff-wx57 Record: https://patchnext.com/advisories/cve-2026-64859 (revision 3, source checked 26 Oct 2026, 15:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/QuantumNous/new-api 1.0.0-rc.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/QuantumNous/new-api: affected < 1.0.0-rc.7; fixed in 1.0.0-rc.7 ## Suggested inspection (read-only) - Go github.com/QuantumNous/new-api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/QuantumNous/new-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6x2c-phff-wx57 (OSV record GHSA-6x2c-phff-wx57 lists affected ranges: Go github.com/QuantumNous/new-api >=0 <1.0.0-rc.7 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6240 (OSV record GO-2026-6240 lists affected ranges: Go github.com/QuantumNous/new-api >=0 <1.0.0-rc.7 (fixed)) - Verified: https://github.com/advisories/GHSA-6x2c-phff-wx57 (GitHub-reviewed advisory GHSA-6x2c-phff-wx57 lists affected ranges: Go github.com/QuantumNous/new-api >=0 <1.0.0-rc.7) Commands are suggestions: review each one before running it.
Loading voting…