Home Assistant Core vulnerable to Path Traversal via backup upload during onboarding
CVE-2026-64825GHSA-5hxg-r395-fqxx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (homeassistant 2026.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI homeassistant
- Affected
- < 2026.6.0
- Fixed in
- 2026.6.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5hxg-r395-fqxx lists affected ranges: PyPI homeassistant >=0 <2026.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5hxg-r395-fqxx lists affected ranges: PyPI homeassistant >=0 <2026.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:H/SA:L · score source
- EPSS
- CVE-2026-64825: 0.58% estimated exploitation activity in the next 30 days; percentile 47.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Home Assistant Core before 2026.6.0 contains a path traversal vulnerability that allows unauthenticated attackers to write arbitrary files to any directory on the host filesystem by uploading a crafted backup archive during the initial onboarding window. Attackers can manipulate the 'name' field inside the uploaded archive's backup.json to supply an absolute path, causing pathlib.Path.truediv to discard the configured backup directory prefix and write attacker-controlled content to arbitrary locations, with full filesystem access when the process runs as root.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-5hxg-r395-fqxx
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-5hxg-r395-fqxx
- Revision 1 · created ·
Published from ghsa record GHSA-5hxg-r395-fqxx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-64825 Advisory: Home Assistant Core vulnerable to Path Traversal via backup upload during onboarding IDs: CVE-2026-64825, GHSA-5hxg-r395-fqxx Record: https://patchnext.com/advisories/cve-2026-64825 (revision 4, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: homeassistant 2026.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI homeassistant: affected < 2026.6.0; fixed in 2026.6.0 ## Suggested inspection (read-only) - `python -m pip show homeassistant`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on homeassistant. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5hxg-r395-fqxx (GitHub-reviewed advisory GHSA-5hxg-r395-fqxx lists affected ranges: PyPI homeassistant >=0 <2026.6.0) - Verified: https://osv.dev/vulnerability/GHSA-5hxg-r395-fqxx (OSV record GHSA-5hxg-r395-fqxx lists affected ranges: PyPI homeassistant >=0 <2026.6.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…