Skip to content

← Actionable
Medium, CVSS 4.3amended

Statamic: Missing authorization on Control Panel endpoint allows disclosure of user existence

CVE-2026-64664GHSA-225x-3jhx-wh4q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (statamic/cms 6.24.0, 5.74.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist statamic/cms

    Affected
    < 5.74.1>= 6.0.0, < 6.24.0
    Fixed in
    6.24.0, 5.74.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-64664: 0.34% estimated exploitation activity in the next 30 days; percentile 27.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated Control Panel user could use an endpoint intended for the user creation wizard to determine if a given email address belongs to an existing user, without having permission to view users. The endpoint only exposed user existence, not any of its data. Patches This has been fixed in 5.74.1 and 6.24.0.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-225x-3jhx-wh4q

  2. Revision 1 · created ·

    Published from osv record GHSA-225x-3jhx-wh4q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-64664

Advisory: Statamic: Missing authorization on Control Panel endpoint allows disclosure of user existence
IDs: CVE-2026-64664, GHSA-225x-3jhx-wh4q
Record: https://patchnext.com/advisories/cve-2026-64664 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: statamic/cms 6.24.0, 5.74.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist statamic/cms: affected < 5.74.1; >= 6.0.0, < 6.24.0; fixed in 6.24.0, 5.74.1

## Suggested inspection (read-only)
- Packagist statamic/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on statamic/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-225x-3jhx-wh4q (OSV record GHSA-225x-3jhx-wh4q lists affected ranges: Packagist statamic/cms >=0 =6.0.0 <6.24.0 (fixed))
- Verified: https://github.com/advisories/GHSA-225x-3jhx-wh4q (GitHub-reviewed advisory GHSA-225x-3jhx-wh4q lists affected ranges: Packagist statamic/cms >=0 =6.0.0 <6.24.0)

Commands are suggestions: review each one before running it.

Loading voting…