Statamic: Unsafe method invocation via Antlers template resolution allows data destruction
CVE-2026-64663GHSA-j2vp-f2pv-5rj4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (statamic/cms 6.24.0, 5.74.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist statamic/cms
- Affected
- < 5.74.1>= 6.0.0, < 6.24.0
- Fixed in
- 6.24.0, 5.74.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j2vp-f2pv-5rj4 lists affected ranges: Packagist statamic/cms >=0 =6.0.0 <6.24.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j2vp-f2pv-5rj4 lists affected ranges: Packagist statamic/cms >=0 =6.0.0 <6.24.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H
- EPSS
- CVE-2026-64663: 0.40% estimated exploitation activity in the next 30 days; percentile 33.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Manipulating user-supplied input incorporated into Antlers templates could result in the loss of content and assets. Exploitation requires a site to have templates that pass untrusted input into affected areas. It does not require authentication. Patches This has been fixed in 5.74.1 and 6.24.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-j2vp-f2pv-5rj4
- Revision 1 · created ·
Published from osv record GHSA-j2vp-f2pv-5rj4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-64663 Advisory: Statamic: Unsafe method invocation via Antlers template resolution allows data destruction IDs: CVE-2026-64663, GHSA-j2vp-f2pv-5rj4 Record: https://patchnext.com/advisories/cve-2026-64663 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: statamic/cms 6.24.0, 5.74.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist statamic/cms: affected < 5.74.1; >= 6.0.0, < 6.24.0; fixed in 6.24.0, 5.74.1 ## Suggested inspection (read-only) - Packagist statamic/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on statamic/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j2vp-f2pv-5rj4 (OSV record GHSA-j2vp-f2pv-5rj4 lists affected ranges: Packagist statamic/cms >=0 =6.0.0 <6.24.0 (fixed)) - Verified: https://github.com/advisories/GHSA-j2vp-f2pv-5rj4 (GitHub-reviewed advisory GHSA-j2vp-f2pv-5rj4 lists affected ranges: Packagist statamic/cms >=0 =6.0.0 <6.24.0) Commands are suggestions: review each one before running it.
Loading voting…