Skip to content

← Actionable
High, CVSS 8.4amended

budibase: Database Connector SQL Injections in PostgreSQL, MS SQL, and MySQL

CVE-2026-64657GHSA-qqf5-x7mj-v43p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (budibase 3.39.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm budibase

    Affected
    < 3.39.19
    Fixed in
    3.39.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-64657: 0.45% estimated exploitation activity in the next 30 days; percentile 38.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary This advisory covers three distinct SQL Injection vulnerabilities within Budibase's database connectors (PostgreSQL, Microsoft SQL Server, and MySQL). Because user-controlled schema and table configurations are interpolated directly into raw SQL queries without proper escaping or parameterization during database introspection, an authenticated administrator can break out of string delimiters. This allows for arbitrary DDL/DML execution, database compromise, and potential underlying OS command execution (e.g., via MS SQL xpcmdshell). Details Vulnerability Type & Title PostgreSQL SET searchpath SQL Injection Description & Root Cause The schema datasource config field is interpolated directly into a raw SQL statement without proper escaping. Double quotes inside the schema name are not escaped, allowing an attacker to break out of the string literal and inject arbitrary SQL. Vulnerable Code: File: packages/server/src/integrations/postgres.ts, lines 355–358 node-postgres sends…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qqf5-x7mj-v43p

  2. Revision 1 · created ·

    Published from osv record GHSA-qqf5-x7mj-v43p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-64657

Advisory: budibase: Database Connector SQL Injections in PostgreSQL, MS SQL, and MySQL
IDs: CVE-2026-64657, GHSA-qqf5-x7mj-v43p
Record: https://patchnext.com/advisories/cve-2026-64657 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: budibase 3.39.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm budibase: affected < 3.39.19; fixed in 3.39.19

## Suggested inspection (read-only)
- `npm ls budibase --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on budibase.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qqf5-x7mj-v43p (OSV record GHSA-qqf5-x7mj-v43p lists affected ranges: npm budibase >=0 <3.39.19 (fixed))
- Verified: https://github.com/advisories/GHSA-qqf5-x7mj-v43p (GitHub-reviewed advisory GHSA-qqf5-x7mj-v43p lists affected ranges: npm budibase >=0 <3.39.19)

Commands are suggestions: review each one before running it.

Loading voting…