Skip to content

← Actionable
Low, CVSS 2.1amended

GitHub CLI allows path traversal through unescaped request URL components

CVE-2026-64653GHSA-4fjg-2h4q-fwg3

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/cli/cli/v2

    Affected
    < 2.97.0
    Fixed in
    2.97.0
  • Go github.com/cli/cli

    Affected
    every version
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2026-64653: 0.51% estimated exploitation activity in the next 30 days; percentile 43.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A path traversal vulnerability has been identified in the GitHub CLI where some HTTP request URLs, REST API calls in particular, were built without properly escaping their variable path components. A value containing URL path metacharacters can alter the request path and cause gh to address a different resource than intended. Details Not all request URLs in the codebase were built with proper escaping of their variable path components. When a component is interpolated into the path without percent encoding, and that component contains URL path metacharacters, it breaks out of its intended segment and changes the effective request path. In 2.97.0, request URLs are constructed in a safe manner, so a variable component can no longer escape its intended segment. Impact An attacker who can control a value that flows into a request path can cause gh to send the request to a different API endpoint than intended. This can lead the CLI to read or act on a resource other than the one…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-4fjg-2h4q-fwg3

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GO-2026-6765

  4. Revision 1 · created ·

    Published from osv record GHSA-4fjg-2h4q-fwg3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-64653

Advisory: GitHub CLI allows path traversal through unescaped request URL components
IDs: CVE-2026-64653, GHSA-4fjg-2h4q-fwg3
Record: https://patchnext.com/advisories/cve-2026-64653 (revision 4, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/cli/cli/v2 2.97.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/cli/cli/v2: affected < 2.97.0; fixed in 2.97.0
- Go github.com/cli/cli: affected every version

## Suggested inspection (read-only)
- Go github.com/cli/cli/v2: check the installed version with your package manager.
- Go github.com/cli/cli: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/cli/cli/v2, github.com/cli/cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6765 (OSV record GO-2026-6765 lists affected ranges: Go github.com/cli/cli >=0; Go github.com/cli/cli/v2 >=0 <2.97.0 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-4fjg-2h4q-fwg3 (OSV record GHSA-4fjg-2h4q-fwg3 lists affected ranges: Go github.com/cli/cli/v2 >=0 <2.97.0 (fixed))
- Verified: https://github.com/advisories/GHSA-4fjg-2h4q-fwg3 (GitHub-reviewed advisory GHSA-4fjg-2h4q-fwg3 lists affected ranges: Go github.com/cli/cli/v2 >=0 <2.97.0)

Commands are suggestions: review each one before running it.

Loading voting…