Next.js: Cache confusion of response bodies for requests with bodies
CVE-2026-64648GHSA-68g3-v927-f742
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.2.11, 15.5.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next
- Affected
- >= 13.0.0, < 15.5.21>= 16.0.0, < 16.2.11
- Fixed in
- 15.5.21, 16.2.11
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-68g3-v927-f742 lists affected ranges: npm next >=13.0.0 =16.0.0 <16.2.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-68g3-v927-f742 lists affected ranges: npm next >=13.0.0 =16.0.0 <16.2.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-64648: 0.34% estimated exploitation activity in the next 30 days; percentile 27.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A server-side fetch with a request body may return a cached response body from a different request to the same URL but different body. Confidential data in the POST's response body would then leak to unauthorized requests. Though the request itself will not be deduped. This only applies to fetch calls with a request that has a different init than the one passed to fetch. Safe: fetch(new Request(init), init) Unsafe: fetch(new Request(init), aDifferentInit) Workarounds No workaround exists besides upgrading. Applications using Pages Router are not vulnerable.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-68g3-v927-f742
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-68g3-v927-f742
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-64648 Advisory: Next.js: Cache confusion of response bodies for requests with bodies IDs: CVE-2026-64648, GHSA-68g3-v927-f742 Record: https://patchnext.com/advisories/cve-2026-64648 (revision 3, source checked 26 Oct 2026, 12:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next 16.2.11, 15.5.21. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next: affected >= 13.0.0, < 15.5.21; >= 16.0.0, < 16.2.11; fixed in 15.5.21, 16.2.11 ## Suggested inspection (read-only) - `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-68g3-v927-f742 (OSV record GHSA-68g3-v927-f742 lists affected ranges: npm next >=13.0.0 =16.0.0 <16.2.11 (fixed)) - Verified: https://github.com/advisories/GHSA-68g3-v927-f742 (GitHub-reviewed advisory GHSA-68g3-v927-f742 lists affected ranges: npm next >=13.0.0 =16.0.0 <16.2.11) Commands are suggestions: review each one before running it.
Loading voting…