Skip to content

← Actionable
High, CVSS 8.3amended

Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname

CVE-2026-64645GHSA-p9j2-gv94-2wf4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.2.11, 15.5.21), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 12.0.0, < 15.5.21>= 16.0.0, < 16.2.11
    Fixed in
    15.5.21, 16.2.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-64645: 0.41% estimated exploitation activity in the next 30 days; percentile 35.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A rewrites() or redirects() rule that builds its external destination hostname from request-controlled input can be pointed at an arbitrary hostname, regardless of the rule's hostname suffix. For a rewrite, Next.js proxies the request to that arbitrary host and serves the response from the application's origin, leading to Server-Side Request forgery. A redirects() rule configured this way is vulnerable to an Open Redirect. This affects any destination that puts a dynamic segment in the hostname, whether from the path: or from a has capture: Workarounds If you cannot upgrade immediately, do not build the hostname of an external rewrites() or redirects() destination from user-controlled input. If a dynamic subdomain is required, constrain the value to hostname-safe characters: value: '(?<region[a-z0-9-]+)'.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p9j2-gv94-2wf4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-p9j2-gv94-2wf4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-64645

Advisory: Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname
IDs: CVE-2026-64645, GHSA-p9j2-gv94-2wf4
Record: https://patchnext.com/advisories/cve-2026-64645 (revision 3, source checked 26 Oct 2026, 12:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.2.11, 15.5.21. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 12.0.0, < 15.5.21; >= 16.0.0, < 16.2.11; fixed in 15.5.21, 16.2.11

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p9j2-gv94-2wf4 (OSV record GHSA-p9j2-gv94-2wf4 lists affected ranges: npm next >=12.0.0 =16.0.0 <16.2.11 (fixed))
- Verified: https://github.com/advisories/GHSA-p9j2-gv94-2wf4 (GitHub-reviewed advisory GHSA-p9j2-gv94-2wf4 lists affected ranges: npm next >=12.0.0 =16.0.0 <16.2.11)

Commands are suggestions: review each one before running it.

Loading voting…