Skip to content

← Actionable
Medium, CVSS 6.3amended

Next.js: Unauthenticated disclosure of internal Server Function endpoints

CVE-2026-64643GHSA-955p-x3mx-jcvp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.2.11, 15.5.21), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 13.0.0, < 15.5.21>= 16.0.0, < 16.2.11
    Fixed in
    15.5.21, 16.2.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-64643: 0.51% estimated exploitation activity in the next 30 days; percentile 43.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In Next.js applications using App Router, Server Actions (use server) or use cache endpoints can be disclosed bypassing any authentication on the pages where these endpoints are usually used. Server Action IDs can be disclosed to unauthenticated users via publicly served client artifacts (for example, static chunks containing action references). Affected users are applications using App Router + Server Actions. By itself, this disclosure is typically a recon/enumeration primitive; however, it can increase risk when combined with other weaknesses. Workarounds Never assume any authentication claims at the use cache or use server boundary. Always authenticate within the boundary.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-955p-x3mx-jcvp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-955p-x3mx-jcvp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-64643

Advisory: Next.js: Unauthenticated disclosure of internal Server Function endpoints
IDs: CVE-2026-64643, GHSA-955p-x3mx-jcvp
Record: https://patchnext.com/advisories/cve-2026-64643 (revision 3, source checked 26 Oct 2026, 12:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.2.11, 15.5.21. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 13.0.0, < 15.5.21; >= 16.0.0, < 16.2.11; fixed in 15.5.21, 16.2.11

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-955p-x3mx-jcvp (OSV record GHSA-955p-x3mx-jcvp lists affected ranges: npm next >=13.0.0 =16.0.0 <16.2.11 (fixed))
- Verified: https://github.com/advisories/GHSA-955p-x3mx-jcvp (GitHub-reviewed advisory GHSA-955p-x3mx-jcvp lists affected ranges: npm next >=13.0.0 =16.0.0 <16.2.11)

Commands are suggestions: review each one before running it.

Loading voting…