Skip to content

← Actionable
Medium, CVSS 6.9

Amazon EFS CSI Driver has mount option injection via unsanitized volumeHandle and mounttargetip fields

CVE-2026-6437GHSA-mph4-q2vm-w2pw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kubernetes-sigs/aws-efs-csi-driver 1.7.8-0.20260416142831-51806c22c575), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-mph4-q2vm-w2pw lists affected ranges: Go github.com/kubernetes-sigs/aws-efs-csi-driver >=0 <1.7.8-0.20260416142831-51806c22c575

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:H/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2026-6437: 0.56% estimated exploitation activity in the next 30 days; percentile 46.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Amazon EFS CSI Driver is a Container Storage Interface driver that allows Kubernetes clusters to use Amazon Elastic File System. An issue exists where, under certain circumstances, unsanitized values in the volumeHandle and mounttargetip fields are passed directly to the mount command, allowing injection of arbitrary mount options. Impact An actor with PersistentVolume creation privileges can inject arbitrary mount options by appending comma-separated values to the Access Point ID in volumeHandle or to the mounttargetip volumeAttribute. The mount utility parses comma-separated values as separate options, causing the injected options to be applied to the filesystem mount without authorization. Impacted versions: <= v3.0.0 Patches This issue has been addressed in Amazon EFS CSI Driver version v3.0.1. We recommend upgrading to the latest version and ensuring any forked or derivative code is patched to incorporate the new fixes. Workarounds Restrict PersistentVolume and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mph4-q2vm-w2pw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-6437

Advisory: Amazon EFS CSI Driver has mount option injection via unsanitized volumeHandle and mounttargetip fields
IDs: CVE-2026-6437, GHSA-mph4-q2vm-w2pw
Record: https://patchnext.com/advisories/cve-2026-6437 (revision 1, source checked 26 Oct 2026, 15:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/kubernetes-sigs/aws-efs-csi-driver 1.7.8-0.20260416142831-51806c22c575. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/kubernetes-sigs/aws-efs-csi-driver: affected < 1.7.8-0.20260416142831-51806c22c575; fixed in 1.7.8-0.20260416142831-51806c22c575

## Suggested inspection (read-only)
- Go github.com/kubernetes-sigs/aws-efs-csi-driver: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/kubernetes-sigs/aws-efs-csi-driver.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mph4-q2vm-w2pw (GitHub-reviewed advisory GHSA-mph4-q2vm-w2pw lists affected ranges: Go github.com/kubernetes-sigs/aws-efs-csi-driver >=0 <1.7.8-0.20260416142831-51806c22c575)

Commands are suggestions: review each one before running it.

Loading voting…