Skip to content

← Actionable
Medium, CVSS 5.9amended

@fastify/static vulnerable to route guard bypass via encoded path separators

CVE-2026-6414GHSA-x428-ghpx-8j92

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/static 9.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-6414: 0.42% estimated exploitation activity in the next 30 days; percentile 36.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact @fastify/static v9.1.0 and earlier decodes percent-encoded path separators (%2F) before filesystem resolution, but Fastify's router treats them as literal characters. This creates a routing mismatch: route guards on /admin/ do not match /admin%2Fsecret.html, but @fastify/static decodes it to /admin/secret.html and serves the file. Applications that rely on route-based middleware or guards to protect files served by @fastify/static can be bypassed with encoded path separators. Patches Upgrade to @fastify/static = 9.1.1. Workarounds None. Upgrade to the patched version.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x428-ghpx-8j92

  2. Revision 1 · created ·

    Published from osv record GHSA-x428-ghpx-8j92

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-6414

Advisory: @fastify/static vulnerable to route guard bypass via encoded path separators
IDs: CVE-2026-6414, GHSA-x428-ghpx-8j92
Record: https://patchnext.com/advisories/cve-2026-6414 (revision 2, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fastify/static 9.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fastify/static: affected >= 8.0.0, <= 9.1.0; fixed in 9.1.1

## Suggested inspection (read-only)
- `npm ls @fastify/static --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fastify/static.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x428-ghpx-8j92 (OSV record GHSA-x428-ghpx-8j92 lists affected ranges: npm @fastify/static >=8.0.0 <9.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-x428-ghpx-8j92 (GitHub-reviewed advisory GHSA-x428-ghpx-8j92 lists affected ranges: npm @fastify/static >=8.0.0 <=9.1.0)

Commands are suggestions: review each one before running it.

Loading voting…